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1Getting Started

System Requirements
The system requirements to install and operate XFINITY Connection Manager are shown in the 
table below.

Additional Requirements: 
• Internet connection (if downloading the software from the Internet)

• CD-ROM drive (if installing from CD)

• Compatible XFINITY Mobile 3G or Mobile 4G Inernet Device for Mobile connections

New Devices Supported
This version of the XFINITY Connection Manager supports the following Mobile Internet 
Devices: 

• Novatel MC760

• Franklin Wireless CMU-301

• Franklin Wireless CMU-600 

• ZTE TU25

• Ubee PXU1903

Operating System Mac 10.5 (Leopard
Mac 10.6 (Snow Leopard)

Processor Intel Based 867 MHz

RAM 512 MB

Hard Drive Space 100 MB

Browser Safari
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Installing the XFINITY Connection Manager Software
Installing the XFINITY Connection Manager is easy. You can install from CD or the Internet. 
Complete the following steps to install the XFINITY Connection Manager software.

Installing from CD
Follow these steps if you are installing from a CD:

1. Insert the XFINITY Connection Manager CD into your CD-ROM or DVD drive.

2. Double-click "Install XFINITY Connection Manager.mpkg.zip" to extract the installer file.

3. Double-click "Install XFINITY Connection Manager.mpkg" to begin the installation.

4. Follow the on-screen instructions for installation and configuration of the XFINITY 
Connection Manager software.

Installing from the Internet
If you have downloaded the XFINITY Connection Manager software, follow these steps to 
complete the installation process:

1. Download the installation program from the Internet.

2. Double click "Install XFINITY Connection Manager.mpkg.zip" to extract the installer file.

3. Double click "Install XFINITY Connection Manager.mpkg" to begin the installation.

4. Follow the on-screen instructions for installation and configuration of the XFINITY 
Connection Manager software.

Note: Once the XFINITY Connection Manager software is installed, supported wireless 
devices will be detected automatically by the XFINITY Connection Manager whenever you 
attach them. 

DO NOT plug the XFINITY Mobile Internet Device into your computer until you have completed 
the XFINITY Connection Manager installation. Inserting the device prior to installing XFINITY 
Connection Manager could result in the device drivers being configured incorrectly.

Launching XFINITY Connection Manager
Once your software is installed and ready to connect, launch the XFINITY Connection Manager 
from the XFINITY Connection Manager folder on your Mac computer as shown in the following 
steps:
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1. On the Finder menu bar on your Mac computer, select Go > Applications. The 
Applications folder is displayed.

2. Double-click XFINITY Connection Manager to access the XFINITY Connection Manager 
folder.

This window initially appears after installation. 
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3. Launch XFINITY Connection Manager by double-clicking XFINITY Connection Manager.

The following files will be in the XFINITY Connection Manager application folder:

• XFINITY Connection Manager (double-click to launch the XFINITY Connection Manager 
application)

• XFINITY Connection Manager Uninstaller (double-click to launch the Uninstaller 
application)

• XFINITY Connection Manager User Guide.pdf (double-click to open the User Guide)
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2The XFINITY Connection 
Manager Interface

Getting Connected
By default, the XFINITY Connection Manager will automatically connect to an available 
network. It will seek to connect to Mobile 4G and Mobile 3G networks (in that order). You can 
also manually connect to a network, by first turning off the auto-connection feature. To do this, 
select 3G or 4G in the Technology List.

If you are already connected to a network whose connections are not managed by the XFINITY 
Connection Manager, you must shut that connection down before establishing a connection 
with the XFINITY Connection Manager (only one connection is allowed at a time).

Note: Manually disconnecting switches off the auto-connect feature until you restart the 
XFINITY Connection Manager application.

1. Select the network to which you want to establish the connection by clicking one of the 
technologies in the Technology List.

2. Click the Connect button to establish a connection to the currently-selected network.

Note: Because only one connection is allowed at a time, any other connection will be shut 
down when you click Connect.

See Chapter 3, “Establishing Mobile Connections” for more information on establishing Mobile 
Mobile 3G and Mobile 4G connections.
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The Main Window
The main interface for establishing wireless connections is shown below. 

This window will display details about the XFINITY network or about one of our partner 
networks when you are roaming. You can do the following from this window:

• Connect or Disconnect to the displayed network by clicking the Connect/Disconnect 
button.

• View the status of the current connection in the Status Text field.

• View the currently used technology type in the Technology List.

• View your account information by clicking on the My XFINITY button.

• View the strength of the current signal on the Signal Strength Indicator.

Connection Indicators
A brief textual description of the connection status for the currently-selected network (for 
example, “Ready to Connect” or “Connected”). If you are currently connected to a particular 
network, the Status Text will indicate Connected: Network Name. If the Mobile 3G network 

displayed is a roaming network, the  symbol will appear on the network signal strength bars. 
if no network is available, the  symbol will appear on the signal strength bars.

Status Text
A brief textual description of the connection status for the currently selected network (for 
example, "Ready to Connect" or "Connected").

The possible states are as follows:
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• Network Available: "Ready: Network Name" is displayed.

• Active Connection: "Connected to: Network Name" is displayed.

• No Network: "No Network Available" is displayed.

• Roaming (3G Only): "Connected to: XFINITY Roaming 3G" is displayed.

• In 4G View when 3G Radio is Active: "4G Inactive" is displayed.

• In 3G View when 4G Radio is Active: "3G Inactive" is displayed.

In addition, various In progress states may be displayed. Some examples are:

• 4G Network Scanning: "Searching for 4G Network" is displayed. With a Dual-Mode 
device, the "Skip to 3G" button is present. With a single-mode device the "Skip to 3G" 
button is not present.

• 3G Network Scanning: "Searching for 3G Network" is displayed. No button is present 
during the 3G network search.

• Switching 4G/3G Radio: "Switching to 3G or 4G" is displayed. Note that the text is 
displayed in all three views in the technology list.

• Connecting to Network: "Connecting to Network Name" is displayed. The Network Name 
is either "XFINITY Mobile 3G" or "XFINITY Mobile 4G".

• Disconnecting: "Disconnecting from Network" is displayed.

Connect / Disconnect
Click this button to connect to (or disconnect from) the network currently selected in the 
technology list. The text displayed on the button is context specific. 

• With an Available Connection: "Connect" is displayed.

• With Current Connection: "Disconnect" is displayed.

• With No Available Network: "Rescan" is displayed.

• With a 3G-Only Device in 4G View: "What's 4G" is displayed.

• With a 4G-Only Device in 3G View: "What's 3G" is displayed.

• With 3G Radio Active in 4G View (CMU 301 Device): "Check Signal" is displayed.

• With 4G Radio Active in 3G View (CMU 301 Device): "Check Signal" is displayed.

If the XFINITY Mobile Device you are currently using is a 4G-only device, this button will 
display a "What's 3G?" link. Click this link to view information on upgrading to 3G/4G dual-
mode service.
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Signal Strength
Indicates the current strength of signals being received from this network. Stronger signals 
tend to produce more reliable connections. 

My XFINITY Button
When connected to one of the networks listed above, clicking this link opens your browser to 
the XFINITY home page.

Controls for the Main Window

The buttons in the upper-left corner of the Main Window control the appearance and location of 
the window.

Menus in the Main Window
The menu bar at the top of your Mac computer will show the following menus when the focus is 
on the XFINITY Connection Manager main window.

XFINITY Connection Manager Menu

About XFINITY Connection Manager
Selecting this item will display a window with Serial Number, Version, and Technical Support 
information. Clicking the System Info button displays your computer's system information. This 
information may be helpful when communicating with technical support.

Preferences
Selecting this item displays the Preferences window. Various settings for XFINITY Connection 
Manager may be changed via the Preferences window.

Click this button to Close the main window.

Click this button to Send the application to the Dock.

This button is grayed-out and not functional.
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Services
This is a Mac OS specific menu item. Items under this menu vary dynamically depending on 
the applications installed and running. Some services can be used by one application, while 
working on another application. If the service is dimmed, you have selected something that 
does not work with that particular service. Please refer to your Macintosh Operating System 
Help for further details on this menu item. 

Hide XFINITY Connection Manager
Selecting this item hides the XFINITY Connection Manager application from your screen. An 
icon remains in the dock. This is useful if you want to keep the XFINITY Connection Manager 
available without terminating an active connection. To return to XFINITY Connection Manager, 
click the XFINITY Connection Manager icon in the dock.

Hide Others, Show All
These are Mac OS specific menu items. Hide Others allows you to hide all other applications 
except the application that is currently selected. Show All allows you to show all the application 
windows.

Quit XFINITY Connection Manager
Select this item to quit the XFINITY Connection Manager application. Quitting the application 
terminates an active 3G or 4G connection.

The File Menu
Click File in the menu bar of the XFINITY Connection Manager's main window to produce a 
menu with the following options:

Enable/Disable XFINITY Mobile 3G
Select this option to enable and disable XFINITY Mobile 3G connections. Use the disable 
option when you want to prevent your Mobile Broadband device from establishing connections 
or consuming you laptop's power.

Enable/Disable XFINITY Mobile 4G
Select this option to enable and disable XFINITY Mobile 4G connections. Use the disable 
option when you want to prevent your Mobile Broadband device from establishing connections 
or consuming your laptop's power.

Close Window
Selecting this item will close the Main Window of the XFINITY Connection Manager, but won't 
quit the application. Active 3G or 4G connections won't be terminated.
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The Tools Menu
Click Tools in the menu bar of the XFINITY Connection Manager's Main window to produce a 
menu with the following options:

Profiles
Select this option to display the Network Profiles window (see page “The Network Profiles 
Window” on page 19). This window is used to create, edit and prioritize network profiles.

My Usage
Select this item to open your default browser to the XFINITY Customer Central Website, where 
you can view your current 3G/4G data usage. You will need your account holder login 
information (the login information you use to pay your bill). An informational dialog box is 
displayed to notify you of your action. This dialog box is displayed each time you click on My 
Usage, until you check the Do Not Show Again box. This item is grayed out when no Internet 
access is available. 

Note: If you have not yet registered for online access, you must click the Click Here to Register 
link in the dialog box to sign up for online access. You can also visit the sign up page at https://
customer.comcast.com.

Upon successful login, with correct credentials, the Users & Settings web page is displayed 
with your 3G/4G data usage displays. 

Diagnostics > XFINITY Mobile Device Info...
Select this item to open the XFINITY Mobile Device Info window. This window displays 
technical information about the Mobile 3G or Mobile 4G network to which you are currently 
connected (if any) and your XFINITY Mobile 3G or Mobile 4G Internet Device.

For more information about the XFINITY Mobile 3G Info Window, see page “” on page 35.

For more information about the XFINITY Mobile 4G Info Window, see page “XFINITY Mobile 
4G Info Window” on page 40.

Diagnostics > General Diagnostics
Select this item to generate a zip file containing diagnostic information. Comcast technical 
support may request to generate and e-mail this file to technical support. This file is saved on 
your desktop with a file name based on the date and time it was created.

Check for Updates
Select this item to check for updates to the XFINITY Connection Manager software and its 
databases.

https://customer.comcast.com/SmartUrl/Secure/Users.aspx
https://customer.comcast.com/
https://customer.comcast.com/
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The Help Menu
Click Help in the menu bar of the XFINITY Connection Manager's Main window to produce a 
menu with the following options:

Search
Enter a term in the Search field to find related menu items and help topics.

XFINITY Connection Manager Help
Select this item to open this help system.

Other Menus
While XFINITY Connection Manager provides its own menus, you will find some menus are 
Mac OS specific, such as the Edit and Window menus. This makes it easier to learn to use 
different applications. 

File, Edit, Window, Help
The XFINITY Connection Manager menu, showing the application’s name in bold, always 
appears at the left side of the menu bar right next to the Apple menu. The XFINITY Connection 
Manager menu contains commands for setting application preferences and quitting the 
application.

XFINITY Connection Manager provides other standard menus, such as the File, Edit, Window, 
and Help menus. Many of the commands in these menus are standard in all your applications 
(for example, the Close Window command is usually in the File menu and the Copy command 
is usually in the Edit menu). Please refer to your Macintosh documentation for descriptions on 
these Mac OS specific menus and menu items. In cases where there are additional XFINITY 
Connection Manager specific menu items, we have described those menu selections.

The Dock Icon
When XFINITY Connection Manager is running, you will see an icon in the Dock on your Mac 
computer. 
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If XFINITY Connection Manager is currently hidden (by selecting Hide XFINITY Connection 
Manager from the XFINITY Connection Manager Menu), you may restore the window by 
clicking on the Dock icon.

XFINITY Connection Manager may also be sent to the Dock by clicking on the yellow Send to 
Dock button in the upper left corner of the Main Window. 

Click on the XFINITY Connection Manager Dock icon to restore the Main Window. 

Control-Click Menu
Placing your cursor over the XFINITY Connection Manager Dock icon, then pressing 
the Control key, while simultaneously clicking your mouse, will display a brief menu with the 
following items:

• Profiles — Opens the Network Profiles window.

• Preferences — Opens the Preferences window.

• Open XFINITY Connection Manager — Opens the main window of the XFINITY 
Connection Manager.

• Options

• Keep in Dock — Keeps the XFINITY Connection Manager icon in the Dock after 
quitting the application.

• Open at Login — Opens XFINITY Connection Manager each time you log in to your 
computer.

• Show in Finder — Opens a Finder window displaying the XFINITY Connection 
Manager application.

• Hide — Hides the XFINITY Connection Manager application. An active network 
connection will not be terminated.

• Quit — Quits the XFINITY Connection Manager application. Quitting the application will 
terminate an active 3G or 4G connection.

The first three items are specific to XFINITY Connection Manager and the last five are native to 
your Mac computer.
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3Establishing Mobile 
Connections

Auto Connect
By default, the XFINITY Connection Manager will automatically select an available wireless 
network and establish a connection. XFINITY Connection Manager will attempt to connect to a 
4G network first, if available. While XFINITY Connection Manager is searching for a 4G 
network, the “Skip to 3G” button will be displayed if you are using a dual-mode device. This 
allows you to choose a 3G connection if desired.

Note: Manually disconnecting switches off the auto-connect feature until you restart the 
XFINITY Connection Manager application.

Manually Connecting to a Mobile Network
By default, the XFINITY Connection Manager will automatically select an available mobile 
network and establish a connection. However, you can choose a different network if you like. To 
manually connect to a mobile network, follow these steps:

1. Connect your XFINITY Mobile Internet Device.

2. Select either 3G or 4G from the Technology List drop-down list box in the main window. 

3. Click the Connect button to connect.

Note: Manually choosing a network to connect to stops the XFINITY Connection Manager from 
automatically connecting to networks for the duration of the session. If you want to return to 
automatic connection mode, you must restart the XFINITY Connection Manager.
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Device States
The status text on the Main Window will display the following device states:

Device Not Found
Device Not Found is displayed if no device is inserted or found.

Device Initializing
Starting Device is displayed when the device is first plugged in and is initializing.

Ready
After the device has initialized it will begin searching for the network. The main window will 
display “Ready” and the network name (that is, XFINITY Mobile 4G or Mobile 3G).
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4Network Profiles

What is a Network Profile?
A network profile contains the configuration information needed to connect to a particular 
network. Mobile Broadband profiles are predefined by XFINITY (though some configuration 
options are available).

Among other things, network profiles allow you to:

• Configure the XFINITY Connection Manager to automatically connect to a network profile 
whenever the associated network is available.

• Prioritize networks to help the XFINITY Connection Manager choose which network to 
connect to.

• Save settings, such as to enable one-click connection.

The Network Profiles Window
The Network Profiles Window appears when you select Profiles from the Tools menu. Use this 
window to edit existing Network Profile settings. 

The left pane of this window lists of all the network profiles that have been defined so far. A 
profile's position in the list indicates its priority. See “Network Profile Priority” on page 20 for 
more information. 
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Network Profile Priority
In the Profiles window, profiles are listed in order of priority. When selecting a network to 
connect to, the XFINITY Connection Manager will choose the topmost network profile for which 
all of the following are true:

• The network described by the profile is available.

• You have a device capable of connecting to the network connected to your computer.

• The Connection Options field on the General tab in the profile's configuration is set to 
either "Automatic" or "Prompt."

Profile priority also determines when the XFINITY Connection Manager will automatically 
switch from one network to another. If you are connected to one network and a higher priority 
network becomes available, the XFINITY Connection Manager will switch to the higher priority 
network.

Note: Automatic connection switching only occurs when in automatic connection mode. 
XFINITY Connection Manager starts out in this mode each time it is launched, but switches to 
manual mode if you manually choose a network and click Connect. To return to automatic 
mode, restart XFINITY Connection Manager.

Changing Profile Priority
To change the priority of a specific profile, select the profile whose priority you would like to 
change. Then, click and drag the selection to move the profile up or down the list.

Editing a Network Profile
You can edit some of the settings contained in network profiles. A reduced set of parameters 
will be available for modification in profiles that were created for you by XFINITY.

1. Select Profiles from the Tools menu. The Profiles window appears.

2. In the left pane of the window, select the Profile you wish to edit.

3. Click the Edit button. The General page appears. See “Preferences: General” on page 25.

4. Make the desired changes.

Note: For XFINITY provided profiles some fields will not be editable.

5. Click Save when you are finished.
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Deleting a Network Profile
Follow these steps to remove a network profile from the Profiles window:

1. Select Profiles from the Tools menu. The Profiles window displays.

2. Select the profile that you want to remove from the list in the left pane of the window.

3. Click the Remove button. A prompt that asks if you are sure you want to delete this profile 
appears.

4. Click Yes to confirm that you want to delete the profile.

Note: You cannot delete network profiles that were created for you by XFINITY.

Profile Properties: General
The General page contains settings that apply to 4G and 3G types of network profiles. To edit 
these items follow the steps below:

1. Select Profiles from the Tools menu. The Network Profiles window appears.

2. Select the Profile you wish to edit in the left pane of the window.

3. Click the Edit button. The General page appears.

4. Make the desired changes. See the General Page Settings below for a list of the settings 
you can change. 

5. Click Save when you are finished.
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General Page Settings
The settings on this page are described below:

Note: Some of the options pictured on this page may not be available if you are editing a profile 
created for you by XFINITY.

Profile Name
This is how the network profile will be displayed in the Profiles window. XFINITY provided 
profile names are not editable.

Connection Options
This setting controls what the XFINITY Connection Manager will do when it detects the network 
you are configuring. There are three options:

• Automatic — The XFINITY Connection Manager will automatically connect to this network 
whenever it is detected.

• Prompt — The XFINITY Connection Manager will ask you whether to connect to this 
network each time the network is detected.

• Manual — Connections to this network may be established using the controls in the main 
window or by selecting it in the Profiles window and then clicking Connect, but the 
XFINITY Connection Manager will not connect to this network automatically.
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Open Browser Window on Connect
Check this box to automatically launch your browser each time you connect to this network. If 
you want the browser to start at a particular Web page each time you connect to this network, 
enter its web address in the Start URL box.
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5XFINITY Connection 
Manager Preferences

Introduction
The Preferences window allows you to configure the behavior of the XFINITY Connection 
Manager software. Among other things, these settings control how the client connects to 
networks, when it retrieves updates and if its connections should time out.

Select Preferences from the XFINITY Connection Manager menu shown below:
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Preferences: General
The General tab contains general settings for the XFINITY Connection Manager software.

The following items can be found on this tab:

Automatically run this application at login
When this box is checked, the XFINITY Connection Manager will be automatically launched 
each time you log in to your computer. This box is checked by default.

Reset all warning messages
XFINITY Connection Manager provides various warning messages that can be disabled if you 
do not want to see them (typically, this involves checking a "Do not show me this message 
again" box). You can turn all of these warning messages back on by clicking the Reset button.
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Preferences: Update
The Update tab allows you to specify when updates to the XFINITY Connection Manager 
software and device firmware are made. 

The following items can be found on this tab:

Automatically download and install
Select this option to have the XFINITY Connection Manager automatically download and install 
product updates at regular intervals.

Note: These updates are silent (occur in the background). You will not see the update wizard 
when updates are downloaded silently.
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Prompt me to download and install
Select this option to have the XFINITY Connection Manager periodically prompt you to 
download and install product updates.

Manually download and install
Select this option if you want product updates to be downloaded only when you manually 
initiate the download process using the Update Now button below.

Update Period
The time between updates can be specified in the Update Period text box. Enter the number of 
days between checks for available updates. 

Update Now
Click Update Now to have the XFINITY Connection Manager check for and download available 
updates now.

Update Services
Clicking on the Update Services button triggers an update to the service profile and parameters 
on the device. Note that Update Services is only applicable to a Dual-Mode or 3G-only device. 
A Dual-Mode device can function as a Dual-Mode or Single-Mode device. You can call 
Customer Care to change your service plan at any time.

A warning prompt is displayed to inform you that Update Services will interrupt any active 
Mobile (3G or 4G) connection.
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Preferences: Hardware
The Hardware tab is used to configure hardware-related settings for connection establishment. 

The following items can be found on this tab:

The Device List
This table lists all the devices connected to your computer that may be used to establish 
network connections. Among other things, this table allows you to:

• Enable and disable individual devices.

• Choose between multiple devices of the same type.

• Configure additional properties for 3G Mobile Internet Devices.

For more information, see “The Device List” on page 29.
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Edit Device Settings
Select this item to edit the Device Properties for a Mobile 3G device in the Device List. To edit 
a device's properties, if available:

1. Highlight the Mobile 3G device you would like to edit.

2. Click Edit Device Settings. See “Device Properties” on page 30.

Allow Simultaneous Connections
If this box is checked, XFINITY Connection Manager will allow you to establish more than one 
connection at a time (for example, you could be connected to both Wi-Fi and 3G or 4G 
concurrently).

If this box is NOT checked, XFINITY Connection Manager will disconnect from its 3G/4G 
connection if another network connection (such as Wi-Fi or Ethernet) is started. By default, 
allow simultaneous connections is turned off.

Edit Profiles
Click this button to open the Profiles window.

The Device List
The device list appears on the Hardware tab of the Preferences window. It is primarily used to 
select and configure connected devices.

Device Column
This column lists all of the network access devices installed on your computer, grouped by the 
connection technologies they use. Each technology type heading is followed by the device 
names of the specific devices of that type that are installed on your computer. The technology 
types are:

• Unmanaged Devices

• WiMAX Devices

• CDMA Devices

Note: The devices listed under Unmanaged Devices are not managed by the XFINITY 
Connection Manager application.
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Selection Column
This column allows you to specify which devices should be used to connect. The choices for 
this column are:

• Automatic: The XFINITY Connection Manager will automatically choose the best device 
for this technology type.

• Manual: Allows you to manually select the device to be used. After selecting this option, 
check the box next to the device you wish to use.

• Disabled: This option is useful when you are using a multi-function wireless device that 
can only use one wireless mode at a time. When using such adapters, you may have to 
temporarily shut down the XFINITY Connection Manager's use of one of these functions 
when you want to use the other technology.

Status Column
This column identifies the operational status of the device. It indicates whether the device is On 
or Off.

Edit Device Settings
Select this item to edit the Device Properties for a Mobile 3G device in the Device List.

1. Highlight the Mobile 3G device you would like to edit.

2. Click Edit Device Settings. (See “Device Properties” on page 30.)

Unmanaged Devices
Unlike other categories in the Device List, "Unmanaged Devices" are NOT supported by the 
XFINITY Connection Manager.

Device Properties
The Device Property window contains three sections used to configure the behavior of 3G 
Mobile Internet Devices connected to your computer. This window is accessed from the 
Hardware tab of the Preferences window. After highlighting the device in the Device column, 
click on the Edit Device Settings button to display the device property window.
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Roaming Selection
Configure permission for the XFINITY Connection Manager to connect to roaming networks. 
Consult your service agreement for more information about roaming service and any charges 
that such service might incur. You can choose one of these options:

• Allow International Roaming — Select this check box to allow roaming on international 
networks. When enabling this setting, your device will acquire international roaming 
systems, where available. International roaming charges will apply, if you do not have an 
international plan.

• Auto — connects to XFINITY’s network when available, using roaming networks only 
when a connection to the XFINITY network is not available.

• XFINITY Only — connects only to XFINITY’s network. Never connects to other networks.

Use the Roam Guard pull-down menu to specify whether you would like the XFINITY 
Connection Manager to display a warning message when you are about to connect to a 
roaming network for which there may be additional roaming charges.

• Always Ask — always prompt before connecting to a roaming network.

• Never Ask — never ask before connecting to a roaming network.

Device Configuration
This group of settings allows you to update the configuration files that reside on your mobile 
broadband device. Choose from the following options:

• Check Disable Service Updates to disable all updates to your device’s configuration. This 
item disables all the other items in the Device Configuration group and disables network-
initiated updates of the same information.
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• Click Activate Device if the selected device has not yet been activated. This will initiate the 
device activation process. Note that this button will not be available if the selected device 
has already been activated.

• Click Update PRL to download the latest Preferred Roaming List. The Preferred Roaming 
List informs your device who XFINITY's current roaming partners are. Keeping this list 
current ensures that your mobile broadband device will select networks with the most 
reasonable roaming fees.

• Click Update Profile to update the profile your device uses to establish connections.

• Click Update Firmware to download the latest version of your mobile broadband device's 
firmware (its onboard operating software).

Note: This group of settings is only available for some mobile broadband devices and will be 
disabled for others.

Disable LED
Check this box if you want to disable the light on your mobile broadband device.

Note: Some of the options described above may not be available for your particular mobile 
device. These items will then show as grayed-out. 

For information on 4G device properties, see “XFINITY Mobile 4G Info Window” on page 40. 
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Preferences: Connection Timeout
The Connection Timeout tab allows you to specify if and when the XFINITY Connection 
Manager automatically shuts down a connection.

Configuring Duration Timeouts
A duration timeout is a maximum time allowed for any connection. So, a duration timeout of 30 
minutes will shut down any connection that lasts longer than 30 minutes.

To configure a duration timeout, check the Enable Duration Timeout box. Then, specify the 
number of minutes after which the timeout should occur.

If you want the XFINITY Connection Manager to warn you before it disconnects for a duration 
timeout, check the Display warning before timeout box.
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Configuring Inactivity Timeouts
Configuring an inactivity timeout instructs the XFINITY Connection Manager to disconnect if 
there has been little or no data exchanged on a connection for a specified number of minutes.

To configure an inactivity timeout, check the Enable Inactivity Timeout box. Then, specify the 
number of minutes of inactivity that will trigger the timeout.
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6Troubleshooting Tools

XFINITY Mobile Device Info Window
To view information about your XFINITY Mobile 3G Internet Device and/or your XFINITY Mobile 
3G connection (if any), select Diagnostics > Mobile Device Info... from the Tools menu. The 
following window appears.

Note: The information displayed in this window is provided by your XFINITY Mobile 3G Internet 
Device and its drivers. In order to display this information your device must be inserted into an 
available USB port on your computer and in a “Ready” or “Connected” state. If the device does 
not provide this information or the information provided is incorrect, this will be reflected in the 
displayed data.
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XFINITY Mobile Device Info: Device Tab

Device Name
The name used internally by software applications to uniquely identify your XFINITY Mobile 3G 
Internet Device.

Device Description
The commercial name of your XFINITY Mobile 3G Internet Device.

Manufacturer
The name of the manufacturer of your XFINITY Mobile 3G Internet Device.

Modem Model
The model name of your XFINITY Mobile 3G Internet Device.
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Revision
The revision field contains manufacturer-specific information about the version of your device. 
It may, for example, contain additional information about your device's model number or its 
firmware version.

ESN/MEID
Your XFINITY Mobile 3G Internet Device's Electronic Serial Number or Mobile Equipment 
Identity (MEID).

Technology
The technology type of the XFINITY Mobile 3G Internet Device you are using.

Firmware Version
The version of your XFINITY Mobile 3G Internet Device's on-board operating software.

Hardware Version
The version of your XFINITY Mobile 3G Internet Device's hardware.

Modem Port
The communications (COM) port that your Mobile 3G Internet Device is currently attached to.

User Name
Your Network Access Identity (NAI), usually in the form of username@companyabc.com.

Phone Number (MDN)
The telephone number of your XFINITY Mobile 3G Internet Device.

Home Carrier Name
The name of the wireless service provider that your XFINITY  considers to be its “home” 
network.

Home Carrier ID
The ID of the wireless service provider that your XFINITY Mobile 3G Internet Device considers 
to be its “home” network.

Prl Version
The version of the file on your device that contains the Preferred Roaming List.



– 38  –

IMSI
Your XFINITY Mobile 3G Internet's IMSI (International Mobile Subscriber Identity) code. The 
IMSI allows any mobile network to know the home country and network of the subscriber.

XFINITY Mobile Device Info: Network Tab

Network Name
The name of the Mobile 3G carrier to which you are currently connected.

System ID
The ID of the network to which your XFINITY 3G Mobile Internet Device is currently connected.

Connected
Indicates whether you are currently connected to a Mobile 3G Broadband network.
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Roaming
Indicates whether you are currently connected to a Mobile 3G Broadband network other than 
XFINITY’s network.

MIP Error
The last Mobile IP Error Code reported by your Mobile 3G Internet Device.

Signal Strength (dBm)
The strength of the signal being received from this network, expressed in dBm.

Data Sent
The amount of data sent over this connection since it was established (in bytes).

Data Received
The amount of data received over this connection since it was established (in bytes).

IP Address
The IP Address you are using for the current Mobile 3G Internet connection. Ordinarily, the 
address displayed here is assigned only for the duration of the current connection. It is most 
likely NOT permanently assigned to your computer.

Gateway Address
The address of the default gateway that has been assigned to your device.

Workmode
The current provisioning mode of the device. Work Mode 1 indicates 3G only service and Work 
Mode 2 indicates both 3G and 4G services are available on the device.
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XFINITY Mobile 4G Info Window
To view information about your XFINITY Mobile 4G Internet Device and/or your Mobile 4G 
connection, select Diagnostics > Mobile Device Info... from the Tools menu. The window 
shown below appears.

Note: The information displayed in this window is provided by your XFINITY Mobile 4G Internet 
Device and its drivers. In order to display this information your device must be inserted into an 
available USB port on your computer and in a “Ready” or “Connected” state. If the device does 
not provide this information or the information provided is incorrect, this will be reflected in the 
displayed data.

XFINITY Mobile 4G Info: Device Tab
This page displays various information about the XFINITY Mobile 4G Internet Device currently 
attached to your computer.

MAC Address
The Hardware Address of the device. MAC (Media Access Control) addresses are pre-
configured by the device's manufacturer and usually cannot be altered. These addresses are 
used for transferring data by hardware-level protocols such as Ethernet or WiMAX (Mobile 4G). 
Higher level protocols such as the TCP/IP Protocol Suite used by the Internet have their own 
addressing schemes, but still rely on the hardware-level protocol for the transfer of data 
between individual nodes on a network.
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Firmware Version
The version of your XFINITY Mobile 4G Internet Device's onboard operating software.

BaseBand Chip
The version of the chip in your XFINITY Mobile 4G Internet Device that formulates the 
baseband Mobile 4G signal.

Calibration Status
This indicates whether your XFINITY Mobile 4G Internet Device has been calibrated.

Antenna Gain Diff
This item is not currently reported by the XFINITY Connection Manager software.

MAC Version
This item is not currently reported by the XFINITY Connection Manager software.

Rx Power
The strength of the signal received.

TX Power
The level of power your 4G Mobile Internet Device is using to transmit.

NAP-ID
The Network Access Point ID.

Library Version
The version of the software interface of the Mobile 4G Internet Device’s mobile chipset.

Driver Version
The version of the driver for this device that is currently installed on your computer.

RF Chip Version
The version of the chip in your Mobile 4G Internet Device that modulates and multiplexes the 
baseband mobile 4G signal for RF transmission.

Antenna Calib
This item is not currently reported by the XFINITY Connection Manager software.
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Tx Power Offset
This item is not currently reported by the XFINITY Connection Manager software.

CINR
Carrier to Interference + Noise Ratio. This is an indication of how strong the desired signal is 
compared to any interfering signals and noise. This gives a slightly more accurate indication of 
the overall quality of the signal received than just the signal strength by itself.

BSID
Base Station ID. The ID of the base station you are currently connected to.

Preamble Index
The Preamble Index of the mobile 4G base station sector you are currently connected to.

XFINITY Mobile 4G Device Info: Network Tab

IP Address
The Internet address your computer is using for the current Mobile 4G network connection. 
Ordinarily, the address displayed here is assigned only for the duration of the current 
connection. It is most likely NOT permanently assigned to your computer.
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Gateway
The address of the device that is responsible for routing all the network traffic you send via 
Mobile 4G.

DNS Server
The address of the server your computer is using to translate textual Internet addresses (like 
XFINITY.com) into numerical addresses used natively by the Internet Protocol.

DHCP Server
The address of the server that assigned your computer's network configuration for the current 
Mobile 4G connection.

WINS Server
The address of the server (if any) that your computer is using to find the names used by 
computers in a Windows workgroup.

Activity
The number of packets of data that your computer has sent and received over the WiMAX 
connection since it was established.
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About XFINITY Connection Manager
Select About XFINITY Connection Manager from the Help menu to see the version number of 
the XFINITY Connection Manager software as well as the website for XFINITY customer 
service.

Click the System Info button to see information about your computer's current configuration, 
which may be useful to a customer service representative in resolving a problem.
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7Troubleshooting 
Procedures

Numbered Errors
The most commonly reported connection errors are listed below, along with some advice on 
their resolution.

Error 67

Possible causes
• Recent service change to the device.

• Mobile Internet Device account credentials have changed.

• Mobile Internet Device is no longer provisioned for service.

• Select Update Services from the XFINITY Connection Manager > Preferences > Update 
tab to manually update your service profile and parameters for your device.

Recommendation
Contact XFINITY Internet 2go Technical Support at 1-866-206-2182 to ensure that the device is 
properly provisioned and there are no problems with the account.

Error 131
Your Mobile Internet Device account credentials may have changed.

Recommendation
Contact XFINITY Internet 2go Technical Support at 1-866-206-2182 to ensure that the device is 
properly provisioned and there are no problems with the account.

Device Issues
In some circumstances, the XFINITY Connection Manager will not be able to use your Mobile 
3G Internet Device  or Mobile 4G Internet Device:

• Device Disabled — (Refer to FAQ “Why is my device disabled?” on page 49 for details)
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• No Wireless Device Detected — (Refer to FAQ “Why is my wireless device not detected?” 
on page 49 for details)

Application Launch Issues

Auto launching of the XFINITY Connection Manager at Startup
The XFINITY Connection Manager installation can be configured to allow the application to 
automatically launch when a computer boots up or when a new user logs into the machine. 
This may (or may not) be the way you prefer it to behave.

Resolution
You can access the setting that controls this behavior by selecting Preferences from the 
XFINITY Connection Manager menu and then choosing the General tab. Check (or uncheck) 
the Automatically run this application on machine startup box to specify whether the XFINITY 
Connection Manager should be automatically launched.
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8Support

Support Information
Support for the XFINITY Connection Manager can be obtained through XFINITY’s website at 
http://customer.comcast.com/2go

Visit the FAQ section for troubleshooting tips on Top FAQs to connect to the XFINITY Internet 
2go service.

Further assistance is available by phone at 1-866-206-2182.

When contacting XFINITY Internet 2go Technical Support, be sure to include the version of the 
Mac Operating System and the type of wireless device you are using as well as a description of 
the problem you are experiencing.

http://customer.comcast.com/2go
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9FAQs

Frequently Asked Questions

Cannot Connect.
Device appears to be not responding or connecting to the 3G or 4G network. The following 
steps will usually help resolve 90% of these issues.

• If this is the first time the device is used, it may take 3-5 minutes for the device to be 
installed, configured and activated.

• Option 1: Re-insert Mobile Broadband device

– Remove device, wait 10 seconds, re-insert device and try to connect again. If above did 
not work: Remove device, then XFINITY Connection Manager > Quit XFINITY Connec-
tion Manager to exit out of the XFINITY Connection Manager, and wait 20 sec. Re-
launch the XFINITY Connection Manager, re-insert device to a different USB port if avail-
able, and try again.

• Option 2: Reboot computer

–  Remove device and reboot computer. With the XFINITY Connection Manager running, 
re-insert device, and try to connect again.

• Option 3: Update the service

–  If you have a Mobile 3G Broadband device, the device profile may need to be updated.

–  Start XFINITY Connection Manager, insert device. Select Update Services from XFIN-
ITY Connection Manager > Preferences > Update tab to manually update service profile 
and parameters for your device.

–  Once the update process is complete, the device will restart and attempt to connect.

• Option 4: Update XFINITY Connection Manager (must have Internet available)

–  Start XFINITY Connection Manager, click on Tools > Check for Updates.

–  If an update is available, download and install it.

–  Launch XFINITY Connection Manager, re-insert device, and try to connect again.
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Which operating systems does the XFINITY Connection Manager 
support?
The XFINITY Connection Manager supports Mac 10.5 (Leopard) and Mac 10.6 (Snow 
Leopard). See “System Requirements” on page 5 for more information on supported system 
configurations.

How do I stop the XFINITY Connection Manager from launching every 
time I restart my PC?
Follow these steps:

1. Select Preferences from the XFINITY Connection Manager menu.

2. Select the General tab.

3. Remove the check from the Automatically run this application at login box.

4. Click OK.

Can I use XFINITY Connection Manager to connect to a Wi-Fi 
network?
XFINITY Connection Manager does not have any control of your Wi-Fi connection. To connect 
to a Wi-Fi network, you can use your Macintosh computer's AirPort. (See "Allow Simultaneous 
Connections" in the “Preferences: Hardware” on page 28.)

Why is my device disabled?
The XFINITY Connection Manager will not be able to use your 3G Mobile Internet Device or 4G 
Mobile Internet Device if the device is "Disabled". All of the devices used by the XFINITY 
Connection Manager can be disabled by Mac OS X. If this is the case, you can re-enable the 
device.

Resolution
You can enable an attached wireless device by selecting Enable Mobile 3G or Enable Mobile 
4G from the File menu.

Why is my wireless device not detected?
The XFINITY Connection Manager will not be able to use your 3G Mobile Internet Device or 4G 
Mobile Internet Device if the presence of the attached device cannot be detected. Failure to 
detect the device may result from any of the following causes:
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• Devices that are not properly inserted. Make sure such devices are firmly seated in the 
appropriate slots.

• The wrong device is selected in the Hardware tab of the Preferences window.

Ordinarily, automatic selection should be specified in the “Selected” column. If Manual 
selection is specified, verify that the selected device is the device you are trying to use. 
See “Preferences: Hardware” on page 28 for more information.

• No driver or incorrect driver installed. Ensure that the correct version of the XFINITY 
Connection Manager with the latest drivers for the device has been installed.
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