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1Getting Started

System Requirements
The minimum system requirements to install and operate the XFINITY Connection Manager 
are shown in the table that follows:

Additional Requirements
• Windows Vista and Windows 7 operation requires a DirectX 9.0 (or better) graphics 

accelerator 

• Internet connection (if downloading the software from the Internet)

• CD-ROM drive (if installing from CD)

• Compatible XFINITY Mobile 3G or Mobile 4G Internet Device for Mobile connections

• Compatible WiFi enabled device for WiFi connections

New Devices Supported
This version of the XFINITY Connection Manager supports the following Mobile Internet 
Devices:

• Novatel MC760

Windows XP Windows VIsta Windows 7

Processor 300 MHz 1 GHz 

(1.25 GHz recommended)

1 GHz 

(1.25 GHz recommended)

RAM 256 MB 1 GB 

(2 GB recommended)

1 GB 

(2 GB recommended)

Hard Drive Space 60 MB 75 MB 75 MB

Internet Explorer IE 5.5 (or higher) IE 7 (or higher) IE 7 (or higher)

Windows Service 
Pack

Service Pack 3 (or higher) Service Pack 2 (or higher) Any

32-Bit or 64-Bit 32-Bit 32-Bit or 64-Bit 32-Bit or 64-Bit
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• Franklin Wireless CMU-300

• Franklin Wireless CMU-301

• Franklin Wireless CMU-600

• ZTE TU25

• Ubee PXU1903

Installing the XFINITY Connection Manager Software
Installing the XFINITY Connection Manager is easy. Complete the following steps to install the 
XFINITY Connection Manager software:

1. Insert the CD into your computer’s CD ROM drive.

2. If your computer automatically starts the installation program from the CD, follow the on-
screen instructions for installation and configuration.

If your computer does not automatically install the software from the CD:

a. Open the My Computer folder (on Windows Vista and Windows 7, this folder is simply 
called Computer.) 

b. Browse to the CD drive in My Computer (or Computer), and double-click on the CD 
drive icon.

c. Double click the “Setup” icon to begin installation. 

d. Follow the on-screen instructions to install and configure the XFINITY Connection 
Manager.

Note: Once the XFINITY Connection Manager software is installed, supported wireless 
devices will be detected automatically by the XFINITY Connection Manager whenever you 
attach them.
. 
DO NOT plug the XFINITY Mobile Internet Device into your computer until you have completed 
the XFINITY Connection Manager Installation. Inserting the device prior to installing the 
XFINITY Connection Manager could result in the device drivers being configured incorrectly. 

Launching the XFINITY Connection Manager
Once your hardware is installed and ready to connect, you may go ahead and launch the 
XFINITY Connection Manager by doing one of the following:
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• Double-click the XFINITY Connection Manager icon on your computer’s desktop

• In the Start menu, select Programs or All Programs > XFINITY > XFINITY Connection 
Manager > XFINITY Connection Manager.
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2The XFINITY Connection 
Manager Interface

Getting Connected
By default, the XFINITY Connection Manager automatically connects to an available Mobile 4G 
or Mobile 3G network. It will seek to connect to WiFi, Mobile 4G and Mobile 3G networks (in 
that order). You can also manually connect to a network, by first turning off the auto-connection 
feature. WiFi connections may require additional configuration first, but the basics of 
establishing a connection are simple:

1. If you are already connected to a network whose connections are not managed by the 
XFINITY Connection Manager, you must shut that connection down before establishing a 
connection with the XFINITY Connection Manager (only one connection is allowed at a 
time). 

Note: Manually disconnecting switches off the auto-connect feature until you restart the 
XFINITY Connection Manager application.

2. Select the network to which you want to establish the connection by clicking one of the 
lines of the Supported Networks List. 

Connect/Disconnect
Button

Click to Open
Wi-Fi Networks List

Supported
Networks
List

Disconnect
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Note:  If more than one available WiFi network is detected, the XFINITY Connection 
Manager selects one for you. To choose a different network, click View All WiFi, which 
displays the complete list of WiFi networks detected (see page 22).

3. Click the Connect button to establish a connection to the currently selected network.

Note:  Because only one connection is allowed at a time, any other connection will be 
shut down when you click Connect.

See Chapter 3, “Establishing Mobile Connections” for more information on establishing Mobile 
3G and Mobile 4G connections. See Chapter 4, “Establishing WiFi Connections” for more 
information on establishing WiFi connections.

Supported Networks List: In Detail
The main window of the XFINITY Connection Manager interface features a list of the supported 
networks. The networks for which you have a supported device installed are displayed in black. 
Those for which you do not have a supported device installed are in gray. 

Note: Networks are displayed in GRAY if the corresponding device has been disabled by the 
Windows operating system.

The columns in this list include the following:

Connection Indicators
If you are currently connected to a particular network, the corresponding connection indicator is 
lit GREEN in XFINITY. Other networks (to which you are not connected) remain GRAY.
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Network Name
Networks supported by the XFINITY Connection Manager are listed in this column. If the 

Mobile 3G network displayed is not XFINITY's network, the  symbol appears next to the 
network's name to indicate that this is a roaming network. 

Status
This column provides a brief textual description of the connection status for the currently-
selected network (for example, “Ready to Connect” or “Connected”). 

If the XFINITY Mobile Internet Device you are currently using is a 4G-only device, this column 
contains a “What's 3G?” link. Click this link to view information on upgrading to 3G/4G dual 
mode service.

Network Type
This column indicates whether each supported network is Mobile (3G or 4G) or WiFi. 
Additionally, an icon appears in this column, if the network to which you are currently 
connected has been secured using encryption technologies.

Signal 
This column indicates the current strength of signals being received from this network. 
Stronger signals tend to produce more reliable connections.
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The Main Window
The main window displays information about your current connection and other wireless 
networks that are available for connection.

Note: If more than one WiFi network is currently available, the XFINITY Connection Manager 
chooses the network to be displayed in the following manner:

1. The last network you connected to (if available) is given the highest preference.

2. Any "preferred" network (networks for which you have a profile) are chosen next, starting 
with the highest priority profile.

3. If no WiFi networks for which you have a profile are available, the network with the 
strongest signal strength is displayed.

Connection Indicators
These indicators are similar to the connection indicators on the leftmost column of the 
Supported Networks List. However, the Mobile indicator indicates a connection to either a 
Mobile 3G network or a Mobile 4G network.

Refresh Button
Click this button to refresh the information in the window.

XFINITY.com
Button

Refresh
Button

Connection
Indicators

Disconnect
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XFINITY.com Button
When connected to one of the networks listed above, clicking this button opens your browser 
to the XFINITY home page.

The main window has the following menus:
• File menu

• Tools menu

• Help menu

The File Menu
Click File in the menu bar of the XFINITY Connection Manager's main window to produce a 
menu with the following options:

Enable/Disable WiFi
Select this option to enable and disable WiFi. Use the disable option when you want to prevent 
your WiFi adapter from establishing connections or consuming your laptop's power. 

Enable/Disable Mobile 3G 
Select this option to enable and disable XFINITY Mobile 3G connections. Use the disable 
option when you want to prevent your XFINITY Mobile 3G Internet Device from establishing 
connections or consuming your laptop's power.

Enable/Disable Mobile 4G
Select this option to enable and disable XFINITY Mobile 4G connections. Use the disable 
option when you want to prevent your XFINITY Mobile 4G Internet Device from establishing 
connections or consuming your laptop's power.

Exit
Exit the XFINITY Connection Manager application and close any wireless connections.

The Tools Menu
Click Tools in the menu bar of the XFINITY Connection Manager's main window to produce a 
menu with the following options:
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Profiles
Select this option to display the Network Profiles window (see page 27). This window is used to 
create, edit and prioritize network profiles.

My Usage
Select this item to open your default browser to the Customer Central Website, where you can 
view your current 3G/4G data usage. You will need your account holder login information (the 
login information you use to pay your bill). An informational dialog box displays to notify you of 
your action. This dialog box displays each time you click My Usage, until you check the Do Not 
Show Again box. This item is grayed out when no Internet access is available. 

Note:  If you have not yet registered for online access, you must click the Click Here to 
Register link, in the dialog box, to sign up for online access. You can also visit the sign up page 
at https://customer.comcast.com.

Upon successful login, with correct credentials, the Users & Settings web page with your 3G/
4G data usage displays.

Diagnostics > WiFi Info
Select this item to open the WiFi Info window. This window displays technical information about 
the WiFi network to which you are currently connected (if any) and the associated WiFi 
enabled device.

Diagnostics > Mobile 3G Info
Select this item to open the Mobile 3G Info window. This window displays technical information 
about the Mobile network to which you are currently connected (if any) and your XFINITY 
Mobile 3G Internet Device.

Diagnostics > Mobile 4G Info
Select this item to open the Mobile 4G Info window. This window displays technical information 
about the Mobile 4G Internet network to which you are currently connected (if any) and your 
XFINITY Mobile 4G Internet Device.

Diagnostics > Event History
Select this item to display a list of the most recent events (for example, network connections, 
network disconnection, errors, etc.).

Diagnostics > Generate Diagnostics
Select this item to generate a file containing diagnostic information; XFINITY technical support 
may ask you to generate and email the file to aid in diagnosing connection problems.
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Check for Updates
Select this item to check for updates to the XFINITY Connection Manager software and its 
databases.

Settings
Select this item to open the Settings window, which allows you to configure a number of 
features to your personal preference.

The Help Menu
Click Help in the menu bar of the XFINITY Connection Manager's main window to produce a 
menu with the following options:

Help
Select this item to open the XFINITY Connection Manager’s help system.

About the XFINITY Connection Manager
Select this item to display version information for the XFINITY Connection Manager software.

Minimizing the Main Window
The buttons in the upper-right corner of the main window control the appearance and location 
of the window.

Minimize Button
Similar to the minimize button in most Windows applications, this reduces the XFINITY 
Connection Manager to a panel on the task bar.

Close
Button

Minimize Button



– 15  –

Click this panel to return the XFINITY Connection Manager to full size.

Close Button
Click this button to close the main window but leave the XFINITY Connection Manager running 
in the background. The smaller version of the main window (shown below) appears in the 
corner of your screen.

After a few seconds, this window closes automatically and only the system tray icon remains 
on the screen (see page 15).

Available Networks
Click the Available Networks link to return to the main window.

Using the System Tray Icon
Whenever the XFINITY Connection Manager software is running, the icon shown below 
appears in the system tray (the row of icons next to the clock on the taskbar). 

The icon remains in the system tray as long as the XFINITY Connection Manager is running, 
even if the main window has been closed. Click once on this icon to open a small window with 
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the ability to connect and disconnect. Note that this smaller version of the main window only 
remains on screen for a few seconds (just long enough to establish a new connection).

Double-click the system tray icon to open the main window (if it is closed) and to move it in 
front of other open applications.

The Right-Click Menu
Right-click the system tray icon to produce a menu with two options:

• Select Settings to open the Settings window (see Chapter 7, “XFINITY Connection 
Manager Settings”).

• Select Exit to close the XFINITY Connection Manager application.
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3Establishing Mobile 
Connections

Manually Connecting to a Mobile Network
By default, theXFINITY Connection Manager automatically selects an available wireless 
network and establish a connection. But, you can choose a different network if you like. To 
manually connect to a mobile network, follow these steps:

1. Connect your XFINITY Mobile Internet Device. 

2. Select either Mobile 4G or Mobile 3G  in the main window.

3. Click the Connect button to connect.

Note:  Manually choosing a network to connect to stops the XFINITY Connection Manager 
from automatically connecting to networks for the duration of the session. If you want to return 
to automatic connection mode, you must restart the XFINITY Connection Manager.
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Mobile 3G Info Window
To view information about your XFINITY Mobile 3G Internet Device and/or your Mobile 3G 
connection, select Diagnostics > Mobile 3G Info from the Tools menu. The Mobile 3G Info 
window appears.

Note: Your mobile number (phone number) is listed on this window as well.

The window includes two tabs:

• Network (See page 59 for more information)

• Device (See page 56 for more information)
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Mobile 4G Info Window
To view information about your XFINITY Mobile 4G Internet Device and/or your Mobile 4G 
connection, select Diagnostics > Mobile 4G Info from the Tools menu. The Mobile 4G Info 
window appears.

The window includes two tabs:

• Network (See page 63 for more information)

• Device (See page 61 for more information)
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4Establishing WiFi 
Connections

Manually Connecting to a WiFi Network
If you have a WiFi enabled laptop, or a computer with an external WiFi device attached, the 
XFINITY Connection Manager enables you to connect to nearby WiFi networks. When there 
are nearby WiFi networks available, the XFINITY Connection Manager selects a network to 
connect to and display its name.

By default, the XFINITY Connection Manager will automatically establish a connection to an 
available wireless network. But, you can choose a different network if you like. Follow these 
steps to connect:

1. Select WiFi in the XFINITY Connection Manager’s main window. 

2. To connect to the network whose name is displayed, click Connect.

To connect to a different network, click the View All WiFi link. The drop-down menu that 
appears lists all available networks (see page 22). Select the network you want to connect 
to and then click the Connect button.

Note: A *closed* item under Network Name indicates the presence of one or more closed 
networks. See “WiFi Info” on page 23 for more information.

Note: Manually choosing a network to connect to stops the XFINITY Connection Manager 
from automatically connecting to networks for the duration of the session. If you want to 
return to automatic connection mode, you must restart the XFINITY Connection Manager.

Prompts
Once the XFINITY Connection Manager has connected to the selected network, you may see 
the following prompts:

• If the network is encrypted, you will be prompted to enter an encryption key. Enter it and 
click OK or click Cancel and select a different network. See “Introduction to WiFi 
Encryption” on page 24 for more information on connecting to encrypted networks.

• When connecting to a WiFi network for the first time, the XFINITY Connection Manager 
may display the New Network Options prompt (see page 21). You can use this dialog box 
to configure the XFINITY Connection Manager to automatically connect to the network in 
the future or to prompt you when that network is available.
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Options for Connecting to a New Network
If Prompt me before saving network settings is selected in the Automatic Profile Creation 
Settings window (see “Automatic Profile Creation Settings” on page 32), you will see the dialog 
pictured below when you connect to a new WiFi Network for the first time. The option selected 
specifies the type of profile that the XFINITY Connection Manager will create for this network. 
By creating a profile automatically, the XFINITY Connection Manager makes it easier for you to 
connect to the same network in the future.

You must choose one the following options:

Automatically connect to network in future
If this option is selected, the XFINITY Connection Manager will automatically connect to this 
network whenever it is detected.

Note: When multiple networks that have been configured for auto-connection are detected, the 
XFINITY Connection Manager connects to the network whose profile is ranked highest in the 
Network Profiles window. See “Network Profile Priority” on page 28 for more information on 
profile rank and how to change it.

Prompt me before connecting to this network
If this option is selected, the XFINITY Connection Manager will notify you when this network is 
detected and offer to establish a connection to it. However, it won’t actually establish the 
connection unless you give your “OK.”

Save settings for manual connections
If this option is selected, the XFINITY Connection Manager will save the connection settings 
you used to connect to this network so that you do not have to enter them again, but it won’t 
connect to this network automatically. To manually connect to this network, select it in the WiFi 
Networks List and then click the Connect button.
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Do not save settings
Choosing this option will allow you to connect to the network this time, but will not save 
parameters for future connections (No profile will be created.)

The List of WiFi Networks
Clicking View All WiFi link in the XFINITY Connection Manager’s main window produces a list 
of all available networks.

Select a network and click the Connect button to connect. 

The information displayed for each network includes the items listed below:

Network Name
The Signal Set IDentifier (SSID) is the name that is broadcast by a WiFi Access Point to 
identify the network.

A *closed* item in this column indicates the presence of one or more closed networks. 
Connecting to such a network requires the creation of a profile for that network. See “WiFi Info” 
on page 23 for more information.

Secured

Encrypted networks display the  icon in this column. See “Introduction to WiFi Encryption” 

on page 24 for instructions on connecting to encrypted networks.

Preferred

A check ( ) is displayed for any WiFi network that is listed in the Network Profiles window. 
This includes WiFi networks for which you have created profiles and Wi-Fi networks for which a 
profile has been created automatically (see “Options for Connecting to a New Network” on 
page 21 for more about automatic profile creation).

Signal Strength
A gauge showing the strength of the signal detected from each network. Stronger signals tend 
to produce more reliable connections.
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WiFi Info
To view information about a WiFi network you are currently connected to or the WiFi device you 
are using to connect to that network, select Diagnostics > WiFi Info from the Tools menu. This 
produces a window with two tabs. 

• The Network tab contains information about the IP Settings for and the amount of Activity 
on your current WiFi connection (if any). 

• The Device tab contains information about your current WiFi device (if any).

What is a Closed Network?
Closed networks are private networks that do not choose to broadcast their existence. The 
XFINITY Connection Manager can detect when there are closed networks present simply 
because it "sees" unidentified broadcasts in the WiFi frequency band. When this happens, the 
word *closed* appears in the WiFi networks list.

However, the XFINITY Connection Manager cannot detect the actual name of or establish a 
connection to a closed network unless you create a profile for that network. For more 
information, see the following:

• How to access a closed network (see below)

• How to create a WiFi Network Profile (see “Creating a Profile for a WiFi Network” on 
page 29)

How to Access a Closed Network
To access a closed network with the XFINITY Connection Manager, you must set up a network 
profile for that network. Follow these steps:

1. Select Profiles from the Tools menu to display the Network Profiles window.

2. Select Add New Profile from the Settings menu. A list of network profile types appears.

3. Select WiFi.

4. Click Add. The first page of properties for the new profile appears.

5. Enter the name of the network you want to add in the SSID field exactly as provided by the 
network administrator.

6. Check This is a non-broadcasted network (Closed) to identify this as a closed network.

7. Fill out the remaining fields on this page as instructed by the network administrator.
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8. Click Next to continue to the General page. 

9. Configure the fields on the General page as desired.

10. Click Finish to exit.

Introduction to WiFi Encryption
Mobile 4G networks and Mobile 3G networks are encrypted and connection to them secured 
using special software in your XFINITY Mobile Internet Devices. Similarly, WiFi networks often 
use encryption technologies to protect data travelling over the network. Unlike Mobile 4G 
networks and Mobile 3G networks, however, connecting to an encrypted WiFi network requires 
that you enter an encryption key. 

What is an Encryption Key?
An encryption key is a code used to encrypt data exchanged between an encrypted network 
and the XFINITY Connection Manager. You must obtain the appropriate encryption key from 
the administrator of an encrypted network in order to connect to that network.

How to Change an Encryption Key
When a network is added to the Network Profile list, all encryption information is saved with it. 
Therefore, you will not be asked for encryption information again when connecting. For security 
purposes, the network administrator may find it necessary to change the encryption key for the 
network. When this happens, you will need to update the encryption keys in the appropriate 
network profile to match the new keys specified by the network administrator. Follow these 
steps:

1. Select Profiles from the Tools menu. The Network Profiles window appears.

2. Select the network for which you wish to edit the encryption keys.

3. Click Edit.

4. Switch to the WiFi tab.

5. Enter the new encryption key in both the Network Key box and the Confirm Network Key 
box.

6. Click the OK button.
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What Does “PSK” Stand For?
PSK stands for “Pre-Shared Key,” which means that your encryption key has to be entered 
manually rather than using a protocol like 802.1x to obtain it from the network as part of the 
connection process. Because of its simplicity, PSK is the typical choice for home and small 
office environments.

Wired Equivalent Privacy (WEP)
WEP is a standard encryption technology that has been used since the early days of WiFi 
networks. Although even more secure methods such as WPA have since emerged, WEP 
remains an extremely popular choice for encrypted networks. There are two variants of WEP:

• WEP Open: This is by far the most commonly-used version of WEP. Networks that use 
WEP Open do not verify that you have the correct encryption key before allowing you to 
connect. However, if you don't have the correct encryption key, you will not be able to 
communicate with the network.

• WEP Shared: The network sends out sample text for the XFINITY Connection Manager to 
encrypt. If the result that the network gets back is what it expected, it allows the 
connection. Ironically, this is somewhat less secure than WEP Open because the 
verification process gives potential intruders a large hint about the contents of the 
encryption key.

WiFi Protected Access (WPA and WPA2)
Developed by an industry trade group known as the WiFi Alliance, WPA is an interim standard 
meant to address the shortcomings of WEP. WPA2 is a newer standard that succeeded WPA, 
but both versions remain in common use.

To use WPA, you need a WPA-compliant WiFi device.

What are TKIP and AES?
Temporal Key Integrity Protocol (TKIP) and Advanced Encryption Standard (AES) are different 
encryption protocols that can be used with WPA. TKIP is the method that was called for in the 
original WPA Specification. AES, which is even more secure, was added as an alternate 
method to later versions of the specification. If network uses WPA, but does not specify which 
one, TKIP is the most likely to be supported by the network.
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Connecting to an Encrypted Network
When you choose to connect to an encrypted network, the software will prompt you to enter a 
network encryption key. To proceed, enter a network encryption key obtained from the network 
administrator and then click the Connect button on the prompt dialog.

Tip: You can create a profile containing the appropriate encryption information to avoid having 
to manually enter an encryption key each time you connect. See “Creating a Profile for a WiFi 
Network” on page 29 for more information.
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5Network Profiles

What is a Network Profile?
A network profile contains the configuration information needed to connect to a particular 
network. Mobile Internet profiles are predefined by Comcast (though some configuration 
options are available). WiFi profiles can be created in the Network Profiles window or created 
automatically when you connect to a new WiFi network.

Among other things, network profiles allow you to:

• Configure the XFINITY Connection Manager to automatically connect using the profile’s 
settings whenever the associated network is available.

• Prioritize networks to help the XFINITY Connection Manager choose which network to 
connect to. 

• Save settings, such as encryption keys for WiFi security or VPN configuration, to enable 
one-click connection.

The Network Profiles Window
Network profiles can be added and configured in the Network Profiles window. To access the 
Network Profiles window, click the Tools > Profiles tab in the main window. 
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The left pane of this window lists all the Network Profiles you have defined so far. Also listed 
are any Network Profiles that have been pre-configured by XFINITY and any profiles 
automatically added when you first connected to a new network. 

A profile's position in the list indicates its priority. See “Network Profile Priority” on page 28 for 
more information. 

Profile Icons
Each profile listed in the Network Profiles window has an icon next to the name. This icon 
indicates the technology that this profile uses to establish connections.

Network Profile Priority
In the Network Profiles window, profiles are listed in order of priority. When selecting a network 
to connect to, the XFINITY Connection Manager will choose the topmost profile for which all of 
the following are true:

• The network described by the profile is available

• You have a device capable of connecting to the network connected to your computer 

• The Connection Options field on the General tab in the profile's configuration is set to 
either “Automatic” or “Prompt”

• The profile is not “Unmanaged Connections” (see Unmanaged Connections that follows).

Profile priority also determines when the XFINITY Connection Manager automatically switches 
from one network to another. If you are connected to one network and a higher priority network 
becomes available, the XFINITY Connection Manager will switch to the higher priority network.

Note: Automatic connection switching only occurs when in automatic connection mode. The 
XFINITY Connection Manager starts out in this mode each time it is launched, but switches to 
manual mode if you manually choose a network and click Connect. To return to automatic 
mode, restart the XFINITY Connection Manager application.

 Mobile 4G

Mobile 3G

 WiFi

 
Unmanaged Connections - this is a placeholder for types of networks not managed 
by the XFINITY Connection Manager. See “Network Profile Priority” on page 28 for 
more information.
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Changing Profile Priority 
To change the priority of a specific profile, select the profile whose priority you would like to 
change. Then, click the Up button or the Down button to move the profile up or down the list.

Unmanaged Connections
“Unmanaged Connections” is not a network profile. It is a placeholder for all network 
connections that are not managed by the XFINITY Connection Manager software. Since 
“Unmanaged Connections” is always at the top of the list, connections of this type always take 
precedence over the wireless connections managed by the XFINITY Connection Manager.

Ethernet LAN connections are an example of connections not managed by the XFINITY 
Connection Manager. Since LAN connections take precedence over managed wireless 
connections, your managed wireless connections will be shut down when you connect to your 
LAN.

Note: You can specify which devices are included in the “Unmanaged Connections” group in 
the Hardware tab of the Settings window.

Creating a Profile for a WiFi Network
Perform these steps to create a WiFi network profile.

1. Click the Tools > Profiles button in the main window. The Network Profiles Window 
displays.

2. Select Add New Profile from the Settings menu. A list of network profile types now 
appears.

3. Select WiFi.
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4. Click the Add button to bring up the first page of the wizard used to create WiFi network 
profiles

5. In the SSID Field, enter the broadcast name of the network to which you will be 
connecting. Note that the name entered here must match the SSID (Service Set 
IDentifier) used by the network exactly.

6. If the network is a Closed network, check the This is a non-broadcast network box.

7. If the network whose profile you are configuring does not use WEP or WPA encryption, 
leave the Enable data encryption box unchecked.

—or—

If the network uses WEP or WPA encryption, check the Enable data encryption box and 
configure the WiFi Data Encryption Settings as explained in “Configuring WiFi Data 
Encryption” on page 31.
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8. Click Next. The General page appears (see page 34).

9. Configure the settings in the General page as desired and then click Finish.

Configuring WiFi Data Encryption
Follow these steps to configure WEP or WPA data encryption:

1. Contact the administrator of the network to obtain information needed for access, such as 
the security method used, encryption keys required, etc. 

2. Check the Enable data encryption box.

3. Select the appropriate Authentication method for this network. Supported authentication 
methods include the following:

• None: For an unencrypted network.

• WEP-Open (Normal Method): This is the standard WEP encryption method.

• WEP-Shared: Similar to WEP-Open, but the base station asks the client to prove that 
it has the right key before the connection is established.

• WPA-PSK (TKIP or AES): This is the pre-shared key version of the WPA protocol.

• WPA2-PSK (TKIP or AES): This is the pre-shared key version of the WPA2 protocol.
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Note: The WPA methods listed above will only be displayed if your WiFi adapter supports 
WPA security.

4. Enter the encryption key for this network in Network Key and Confirm Network Key fields.

Note: Normally, the display of the encryption key is obscured for privacy reasons. If you 
prefer to actually see the key’s text, check the Show network key in clear text box.

Automatic Profile Creation Settings
The XFINITY Connection Manager can automatically create network profiles for each new WiFi 
network you successfully connect to. The setting that controls this can be found by selecting 
Automatic Profile Creation from the Settings menu in the Network Profiles window. Choose 
from the following options:

• Automatically save all networks that I connect to — The XFINITY Connection Manager 
will create a new profile for every new WiFi Network you successfully connect to.

• Prompt me before saving network settings — The XFINITY Connection Manager will ask 
you if you want to create a new profile each time you successfully connect to a new 
network.

• Allow manual input of network settings only — The XFINITY Connection Manager will not 
automatically create network profiles.

Editing a Network Profile
You can edit all of the settings contained in WiFi network profiles. A reduced set of parameters 
will be available for modification in profiles that were created for you by XFINITY.

1. Click the Tools > Profiles button in the main window. The Network Profiles window 
appears.

2. Select the profile you wish to edit in the left pane of the window.

3. Click the Edit button. A tabbed interface showing all the user-editable settings of the 
selected profile appears. Depending on the type of profile you are editing, the following 
tabs may be displayed:

• WiFi (see page 33)

• General (see page 34)

4. Make the desired changes.
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5. Click the OK button when you are finished.

Deleting a Network Profile
Follow these steps to delete a profile from the Network Profiles window:

1. Click the Profiles button in the main window. The Network Profiles window will now be 
displayed.

2. Select the profile that you want to delete from the list in the left pane of the window.

3. Click Remove. A prompt that asks if you are sure you want to delete this profile appears.

4. Click Yes to confirm that you want to delete the profile.

Note: You cannot delete network profiles that were created for you by XFINITY.

Profile Properties: WiFi
The WiFi page contains the security settings for WiFi network profiles.

• The version of this window pictured on the left below appears when creating a new profile. 

• The tabbed version on the right appears when editing an existing profile. 
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Although the window controls vary, the actual parameters included are identical for both 
versions. 

Follow these steps to configure WiFi network security:

1. In the SSID field, enter the name broadcast by the network for which you are creating a 
profile. The name entered here must match the SSID (Service Set IDentifier) used by the 
network exactly.

2. If this is a closed network, check This is a non-broadcast network (closed).

3. If the network does not use WEP or WPA encryption, leave Enable data encryption 
unchecked and no further configuration is necessary on this page.

If the network does use WEP or WPA encryption, check Enable data encryption and 
configure the WiFi data encryption settings. (See “Configuring WiFi Data Encryption” on 
page 31).

Profile Properties: General 
The General page contains settings that apply to all types of network profiles. 

• The version of this window pictured on the left below appears when creating a new profile. 

• The tab version on the right appears when editing an existing profile. 
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Although the window controls vary, the actual parameters included are identical for both 
versions.

Note: Some of the options pictured on this page may not be available if you are editing a profile 
created for you by XFINITY.

Profile Name
The name entered here will be displayed in the Network Profiles window and the XFINITY 
Connection Manager’s main window.

Connection Options
This setting controls what the XFINITY Connection Manager will do when it detects the network 
to which this profile applies. Select one of the following options:

• Automatic — The XFINITY Connection Manager will automatically connect to this network 
whenever it is detected.

• Prompt me — The XFINITY Connection Manager will ask you whether to connect to this 
network each time the network is detected.

• Manual — Connections to this network may be established using the controls in the main 
window or by selecting it in the Network Profiles window and then clicking Connect, but 
the XFINITY Connection Manager will not connect to this network automatically.
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VPN Auto Launch
Check this box if you would like to automatically launch your VPN client software when you 
establish a connection to this network. Click the accompanying Settings button to open the 
VPN tab of the Settings window.

Disable IE’s manual proxy settings on connect
If you normally connect to the Internet through a proxy server (common on corporate LANs), 
you may experience difficulty connecting to the Internet with Internet Explorer when you are 
traveling. This is because Internet Explorer is trying to connect through a proxy server that is 
on your home network rather than on the network to which you are connected.

If this is the case, you can check this box to disable proxy server settings while you are 
connected using this profile.

Launch browser window on connect
Check this box to automatically launch your browser each time you connect to this network. If 
you want the browser to start at a particular Web page each time you connect to this network, 
enter its web address in the Start URL box.



– 37 – 

6Virtual Private Networks 
(VPNs)

What is a Virtual Private Network?
A Virtual Private Network (VPN) is a private network that can be accessed over a public 
backbone network (like the Internet) without compromising the privacy of the VPN. Typically, 
VPNs maintain their privacy by forming secure (encrypted) “tunnels” directly to users who 
access them. For example, a company might set up a VPN for its employees to access their 
corporate network securely when they are away from the office.

The software responsible for forming the tunnel with the private network is called a VPN Client. 
Because the VPN Client and the private network exchange data in an encrypted format, no one 
on the public network over which this information passes can access it.

Supported Clients
Although the XFINITY Connection Manager is not a VPN Client itself, it can automate the 
launching of your VPN Client software when needed. The XFINITY Connection Manager has 
been tested with the following VPN Clients and even automates certain tasks for these clients:

• Microsoft

• Cisco

• Nortel

• Checkpoint (please see “Using the Checkpoint VPN Client” on page 39 for important 
caveats)

• NetMotion (please see “Using the NetMotion VPN Client” on page 40 for important 
caveats)

The XFINITY Connection Manager can also launch other VPN Clients, but may require more 
manual configuration to do so. 

Configuring a VPN Connection
As with any other secure network, accessing a VPN requires some security-related 
configuration. Perform these steps:
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1. Consult the administrator of the VPN you wish to access. The administrator will provide 
you with VPN Client software and instructions for establishing VPN connections.

2. If the VPN Client software is not already installed on your system, install it now. 
(Microsoft's VPN Client is preinstalled on most versions of Windows).

3. Follow your administrator’s instructions for setting up a VPN Login Profile.

4. Access the VPN tab by selecting the Settings option in the Tools menu and then clicking 
the VPN tab.

5. If the VPN client software you are using is supported by the XFINITY Connection 
Manager, select Use existing VPN profile. Then, specify the client software and the login 
profile that you want to use.

If the VPN Client software you are using is NOT supported by the XFINITY Connection 
Manager, select Use Third Party VPN Client. Then, click the Browse button to specify the 
location of the client software that you are using.

6. Click the OK button to exit the Settings window.

Once your VPN Settings have been configured, you can configure network profiles to 
automatically start your VPN Session upon connection. See “Automatically Launching a VPN 
Connection” on page 38.

Automatically Launching a VPN Connection
You can configure a network profile to automatically launch your VPN Client and log into a VPN 
once the connection to a wireless network has been established. Follow these steps:

1. If you have not already done so, configure the connection settings for the VPN you wish to 
connect to. (See “Configuring a VPN Connection” on page 37).

2. Open the Network Profiles window by clicking the Tools > Profiles button in the main 
window.

3. In the left pane, select the profile for which you want to automate VPN connections.
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4. Click the Edit button. The Edit Profile window for the selected profile appears.

5. If the General tab is not already selected, select it now.

6. Check the Auto Launch box.

7. Click OK to exit.

Tip: If you want your VPN Client to be launched automatically with all (or most) of the new 
profiles you create, consider checking the Set VPN Auto Launch for newly created connection 
profiles box on the VPN tab of the Settings window. This configures the default behavior of all 
newly created profiles.

Using the Checkpoint VPN Client
Although CheckPoint's VPN client provides a command line interface that applications such as 
the XFINITY Connection Manager can use to establish connections, the user cannot access 
other modes of the CheckPoint VPN client while the client is in command line mode.

What does this mean for CheckPoint VPN users? Essentially, you should keep the XFINITY 
Connection Manager open only when you have an active connection managed by the XFINITY 
Connection Manager open. If you want to establish another type of connection with the 
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CheckPoint VPN client, you MUST shut down the XFINITY Connection Manager first. When 
the XFINITY Connection Manager shuts down, it will put the VPN client back into a mode that 
users can access.

Using the NetMotion VPN Client
NetMotion's VPN client takes complete control of all data communication to and from your 
computer. This forces all data communication applications to go through the “tunnel” it creates. 
However, the XFINITY Connection Manager needs to bypass this tunnel in order to establish 
connections. The XFINITY Connection Manager will accomplish this in one of the following 
ways:

• The NetMotion VPN client maintains a list of applications that are allowed to bypass its 
VPN tunnel. If your VPN administrator has added the XFINITY Connection Manager to 
this list, the XFINITY Connection Manager can establish connections without interrupting 
the operation of the NetMotion client.

• If the XFINITY Connection Manager has not been added to NetMotion's bypass list, the 
XFINITY Connection Manager will detect that the NetMotion client is interfering with its 
operations when it attempts to establish a connection. When this happens, it will instruct 
the NetMotion client to enter bypass mode (which allows all applications to bypass its 
tunnel) while the connection is being established. Once the connection has been 
successfully established, the XFINITY Connection Manager will return the NetMotion 
client to its normal operating mode.
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7XFINITY Connection 
Manager Settings

Introduction
The Settings window allows you to configure the behavior of the XFINITY Connection Manager 
software. Among other things, these settings control how the client connects to networks, when 
it retrieves updates and if its connections should time out.

To access the Settings window, select Tools > Settings on the main menu.

Settings: General
The General tab contains general settings for the XFINITY Connection Manager software. 
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Automatically run this application on machine startup
When this box is checked, the XFINITY Connection Manager is launched automatically each 
time you start your computer.

Use this as my default WiFi management utility
If this box is checked, the XFINITY Connection Manager manages all WiFi connections on your 
computer when it is running. If you wish to return control of WiFi connections to the operating 
system (or to another application), you must exit the XFINITY Connection Manager software.

When this box is NOT checked, the XFINITY Connection Manager's WiFi functionality is 
disabled.

Settings: Updates
The Updates tab allows you to specify when updates to the XFINITY Connection Manager 
software and device firmware are made.

The following items can be found on this tab:
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Automatically download and install
Select this option to have the XFINITY Connection Manager automatically download and install 
product updates at regular intervals (once a week).

Note: These updates are silent (occur in the background). You do not see the update wizard 
when updates are downloaded silently.

Prompt me to download and install
Select this option to have the XFINITY Connection Manager periodically prompts you to 
download and install product updates.

Manually download and install
Select this option if you want product updates to be downloaded only when you click the 
Update Now button.

Update Now
Click Update Now to have the XFINITY Connection Manager immediately check for and 
download available updates.

Update Services
Clicking on the Update Services button triggers an update to the service profile and parameters 
on the device. Note that Update Services is only applicable to a Dual Mode or 3G-Only device. 
A Dual Mode device can function as a Dual Mode or Single Mode device. You can call 
Customer Care to change your service plan at any time.

A warning prompt is displayed to inform you that Update Services will interrupt any active 
Mobile (3G or 4G) connection.
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Settings: Hardware
The Hardware tab is used to configure hardware-related settings for connection establishment.

The following items can be found on this tab:

The Device List
This table lists all the devices connected to your computer that may be used to establish 
network connections. Among other things, this table allows you to:

• Enable and disable individual devices.

• Choose between multiple devices of the same type.

• Configure additional properties for XFINITY Mobile 3G Internet Devices.

 For more information, see “The Device List” on page 45.
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Prompt before switching connections
When in automatic connection mode, the XFINITY Connection Manager software automatically 
switches to a higher priority network if one becomes available. This has the potential to disrupt 
any activity that was relying on the original connection.

Checking this box will cause the XFINITY Connection Manager to prompt you for permission 
before establishing the connection to the new network.

The Profiles Button
Click this button to open the Network Profiles window.

The Device List
The device list is a table that appears on the Hardware tab of the Settings window. It is 
primarily used to select and configure connected devices.

Devices Column
This column lists all the network access devices installed on your computer, grouped by the 
connection technologies they use. Each technology type heading is followed by the device 
names of the specific devices of that type that are installed on your computer. The technology 
types are:

• WiFi Devices

• Mobile 3G Devices

• Mobile 4G Devices

• Unmanaged Devices

Note: The network devices listed under Unmanaged Devices are not managed by the XFINITY 
Connection Manager application. So, the configuration in this window works a bit differently for 
them. See “Unmanaged Devices” on page 46 for more information.

Selection Column
This column allows you to specify which devices should be used to connect. The choices for 
this column are:

• Automatic: The XFINITY Connection Manager automatically chooses the best device for 
this technology type.

• Manual: Allows you to manually select the device to be used. After selecting this option, 
check the box next to the device you wish to use.
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• Disabled: This option is useful when you are using a multifunction wireless device that can 
only use one wireless mode at a time. For example, you may have a WiFi/Mobile Internet 
Device that can not access both types of network at the same time. When using such 
devices, you may have to temporarily shut down the XFINITY Connection Manager's use 
of one of these functions when you want to use the other technology.

Status Column
This column identifies the operational status of the device. It indicates whether the device is On 
or Off.

Property Column
Additional properties (such as roaming) may be configured for devices if a Modify button is 
displayed in this column. Click Modify to open a pop-up window that provides additional 
configuration options for the device. Currently, only XFINITY Mobile 3G Internet Devices have 
such a window. (For more information, see“Device Properties” on page 47)

Unmanaged Devices
Unlike other categories in the device list, “Unmanaged Devices” are NOT supported by the 
XFINITY Connection Manager. Although the XFINITY Connection Manager cannot use these 
devices to establish connections, it can detect when a device in this category has established a 
connection and (if you desire) shut down its own connections when this occurs. 

To monitor the connection status of a device in this group, check the box in the Selected 
column. Connections for all checked devices will be included in the Unmanaged Connections 
group in the Network Profiles window. For more information, see “Network Profile Priority” on 
page 28.

Note: The Automatic/Manual Disabled drop-down menu at the top of the Unmanaged Devices 
group must be set to Manual to change which devices are checked. This menu also 
determines the default state of the checkbox for newly-detected devices:

• If the drop-down menu is set to Automatic, new devices added to the other group will be 
checked by default.

• If the drop-down menu is set to Manual, new devices will be unchecked by default. 
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Device Properties
The Device Properties window contains three sections used to configure the behavior of 
Mobile 3G devices connected to your computer.

Roaming Selection
Configure permission for the XFINITY Connection Manager to connect to roaming networks. 
Consult your service agreement for more information about roaming service and any charges 
that such service might incur. You can choose one of these options:

• Auto — connects to XFINITY’s network when available, using roaming networks only 
when a connection to XFINITY’s network is not available.

• Home Only — connects only to XFINITY’s network. Never connects to other networks.
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Roam Guard
Use the Roam Guard pull-down menu to specify whether you would like the XFINITY 
Connection Manager to display a warning message when you are about to connect to a 
roaming network for which there may be additional roaming charges.

• Always Ask: always prompt before connecting to a roaming network.

• Never Ask: never ask before connecting to a roaming network.

• Default: display the prompt when the Extended Roaming Indicators (ERI) file on your 
mobile device says it is necessary to do so.

Device Configuration
This group allows you to update the configuration files that actually reside on your mobile 
device. 

Note: This group of settings is only available for some Mobile Broadand devices. 

The options here include the following:

• Check Disable Service Updates if you want to disable all updates to your device's 
configuration. This item disables all the other items in the Device Configuration group and 
disables network-initiated updates of the same information.’

• Click Activate Device if the selected device has not yet been activated. This will initiate the 
device activation process. Note that this button will not be available if the selected device 
has already been activated.

• Click Update PRL to download the latest Preferred Roaming List. The Preferred Roaming 
List informs your device who XFINITY’s current roaming partners are. Keeping the list 
current ensures that your device will select networks with the most reasonable roaming 
fees.

• Click Update Profile to update the profile your device uses to establish connections.

• Click Update Firmware to download the latest version of your device's firmware (its 
onboard operating software).
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Settings: Connection Timeout
The Connection Timeout tab allows you to specify if and when the XFINITY Connection 
Manager automatically shuts down a connection.

Configuring Duration Timeouts
A duration timeout is a maximum time allowed for any connection. So, a duration timeout of 30 
minutes shuts down any connection that lasts longer than 30 minutes.

To configure a duration timeout, check the Enable Duration Timeout box. Then, specify the 
number of minutes after which the timeout should occur. 

If you want the XFINITY Connection Manager to warn you before it disconnects for a duration 
timeout, check the Display warning before timeout box.

Configuring Inactivity Timeouts
Configuring an inactivity timeout instructs the XFINITY Connection Manager to disconnect if 
there has been little or no data exchanged on a connection for a specified number of minutes.

To configure an inactivity timeout, check the Enable Inactivity Timeout box. Then, specify the 
number of minutes of inactivity that will trigger the timeout.
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Settings: VPN
The VPN tab specifies how the XFINITY Connection Manager accesses Virtual Private 
Networks.

The top item, Do Not Use VPN, disables the XFINITY Connection Manager's capacity to log 
into VPNs. Select this option if you do not wish to establish connections to Virtual Private 
Networks.

You must choose one of the other two options and fill in the corresponding fields if you wish to 
automatically log into a VPN when you connect to a specific network (see “Automatically 
Launching a VPN Connection” on page 38).

Use existing VPN profile
Select this item if the VPN client software you will be using is supported by the XFINITY 
Connection Manager. Then, specify the supported client software and the login profile that you 
want to use. See “Supported Clients” on page 37 for more information on supported VPN client 
software.
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Use third party VPN client
Select this item if the VPN client software you will be using is NOT supported by the XFINITY 
Connection Manager. Follow these steps to configure the XFINITY Connection Manager to 
launch the unsupported software:

1. Click the Browse button.

2. Select the program file to be launched.

3. Click Open. The path of the selected file appears in the Command Line box.

4. If your VPN client software requires that additional parameters be included after the 
program filename on the command line, these may be entered in the Parameters box. 
Consult the documentation for your VPN client to determine if such parameters are 
needed.

See “Supported Clients” on page 37 for more information on which VPN client software is 
supported.

Set VPN autolaunch for newly created connection profiles
If this box is checked, all new network profiles created will be configured to automatically 
launch your VPN upon successful connection. If this box not checked, new profiles will not 
connect to your VPN until you follow the instructions in Automatically Launching a VPN.

Note: This setting specifies the initial state of the VPN Autolaunch box on the General page of 
settings for each new profile (see page 36). You can easily change this setting for an individual 
profile after the profile is created.
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8Troubleshooting Tools

Event History Manager
Select Diagnostics > Event History from the Tools menu to see a log of events (for example, 
connections, disconnections, errors). The window shown below appears.

• You can do the following in this window:

• Double-click any item in the list to see more information about that event.

• Use the options in the Filter by section to limit the events displayed to a particular date 
range, connection technology or event type.

• Click on the Reset Event History Manager button to delete all the currently logged events.

• Click on the Export Log button to save the currently logged events information to a text file.

• Check your total usage data by viewing the statistics listed under Mobile Usage Since Last 
Reset.

Note: Byte Totals displayed are approximate and do not include any currently in-progress 
session. More information about data usage is available at XFINITY Customer Central 
(https:// customer.comcast.com/Secure/Users.aspx).
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WiFi Network Information
To view information about a WiFi network you are currently connected to or about your current 
WiFi device, select Diagnostics > WiFi Info from the Tools main menu. This produces the 
window shown below:

Network Tab

IP Address
The Internet address your computer is using for the current WiFi network connection. 
Ordinarily, the address displayed here is assigned only for the duration of the current 
connection. It is most likely NOT permanently assigned to your computer.

Gateway
The address of the device that is responsible for routing all the network traffic you send over 
the WiFi connection.
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DNS Server
The address of the server your computer is using to translate textual Internet addresses (like 
XFINITY.com) into the numerical addresses used natively by the Internet Protocol.

DHCP Server
The address of the server that assigned your computer's network configuration for the current 
wireless connection.

WINS Server
The address of the server (if any) that your computer is using to find the names of computers 
on a Windows network. 

Activity
The number of packets of data that your computer has sent and received over the WiFi 
connection since it was established.
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Device Tab

Vendor Description
The name of your WiFi device, as reported by its on-board operating software.

MAC Address
The Hardware Address of the device. MAC (Media Access Control) addresses are 
pre-configured by the device's manufacturer and usually cannot be altered. These addresses 
are used for transferring data by hardware-level protocols such as Ethernet and 802.11 (WiFi). 
Higher level protocols such as the TCP/IP Protocol Suite used by the Internet have their own 
addressing schemes, but still rely on the hardware-level protocol for the transfer of data 
between individual nodes on a network.

Driver Version
The version of the driver for the device that is currently installed on your computer.

Firmware Version
The version of the device's on-board operating software.
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Mobile 3G Info Window
To view information about your Mobile 3G Internet Device and/or your Mobile 3G connection (if 
any), select Diagnostics > Mobile 3G Info from the Tools menu. The window shown below will 
appear.

Note: The information displayed in this window is provided by your XFINITY Mobile 3G Internet 
Device and its drivers. If the device does not provide this information or the information 
provided is incorrect, this will be reflected in the displayed data.

Device Tab

Device Name
The name used internally by software applications to uniquely identify your Mobile 3G Internet 
Device.
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Device Description
The commercial name of your XFINITY Mobile 3G Internet Device.

Manufacturer
The name of the manufacturer of your XFINITY Mobile 3G Internet Device. 

Modem Model
The model name of your XFINITY Mobile 3G Internet Device.

Revision
The revision field contains manufacturer-specific information about the version of your device. 
It may, for example, contain additional information about your device's model number or its 
firmware version.

ESN
Your XFINITY Mobile 3G Internet Device's Electronic Serial Number.

Technology
The type of XFINITY Mobile 3G Internet Device you are using.

Firmware Version
The version of your XFINITY Mobile 3G Internet Device's on-board operating software.

Hardware Version
The version of your device's hardware.

Modem Port
The communications (COM) port that your XFINITY Mobile 3G Internet Device is currently 
attached to.

User Name
Your Network Access Identity (NAI), usually in the form of username@companyabc.com.

Phone Number (MDN)
The telephone number of your XFINITY Mobile 3G Internet Device.
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Home Carrier Name
The name of the wireless service provider that your XFINITY Mobile 3G Internet Device 
considers to be its “home” network.

Home Carrier ID
The ID of the wireless service provider that your device considers to be its “home” network.

PRL Version
The version of the file on your device that contains the Preferred Roaming List.

MSID (IMSI_S)
Your XFINITY Mobile 3G Internet Device's IMSI (International Mobile Subscriber Identity) code. 
The IMSI allows any mobile network to know the home country and network of the subscriber.
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Network Tab

Network Name
The name of the Mobile 3G carrier to which you are currently connected.

System ID
The ID of the network to which your XFINITY Mobile 3G Internet Device is currently connected.

Connected
Indicates whether you are currently connected to a Mobile 3G network.

Roaming
Indicates whether you are currently connected to a Mobile 3G network other than a Home 
network.
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MIP Error
The last Mobile IP Error Code reported by your XFINITY Mobile 3G Internet Device.

Signal Strength (dBm)
The strength of the signal being received from this network, expressed in dBm. 

Data Sent
The amount of data sent over this connection since it was established (in bytes).

Data Received
The amount of data received over this connection since it was established (in bytes).

IP Address
The IP Address you are using for the current XFINITYMobile 3G Internet connection. 
Ordinarily, the address displayed here is assigned only for the duration of the current 
connection. It is most likely NOT permanently assigned to your computer.

Gateway Address
The address of the default gateway that has been assigned to your device.
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Mobile 4G Info Window
To view information about your XFINITY Mobile 4G Internet Device and/or your Mobile 4G 
connection (if any), select Diagnostics > Mobile 4G Info from the Tools menu. The window 
shown below appears:

Note: The information displayed in this window is provided by your XFINITY Mobile 4G Internet 
Device and its drivers. If the device does not provide this information or the information 
provided is incorrect, this will be reflected in the displayed data.

Device Tab

This page displays various information about the XFINITY Mobile 4G Internet Device currently 
attached to your computer.

MAC Address
The Hardware Address of the device. MAC (Media Access Control) addresses are 
preconfigured by the device's manufacturer and usually cannot be altered. These addresses 
are used for transferring data by hardware-level protocols such as Ethernet or WiMAX. Higher 
level protocols such as the TCP/IP Protocol Suite used by the Internet have their own 
addressing schemes, but still rely on the hardware-level protocol for the transfer of data 
between individual nodes on a network.

Library Version
The version of the software interface of the device’s Mobile 4G chipset.
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Firmware Version
The version of your XFINITY Mobile 4G Internet Device's onboard operating software.

Driver Version
The version of the driver for the device that is currently installed on your computer.

BaseBand Chip
The version of the chip in your XFINITY Mobile 4G Internet Device that formulates the 
baseband Mobile 4G signal.

RF Chip Version
The version of the chip in your XFINITY Mobile 4G Internet Device that modulates and 
multiplexes the baseband Mobile 4G signal for RF transmission.

Calibration Status
This indicates whether your XFINITY Mobile 4G Internet Device has been calibrated.

Antenna Calib
This item is not currently reported by the XFINITY Connection Manager software.

Antenna Gain Diff
This item is not currently reported by the XFINITY Connection Manager software.

Tx Power Offset
This item is not currently reported by the XFINITY Connection Manager software.

MAC Version
This item is not currently reported by the XFINITY Connection Manager software.

The Advanced Button
Click this button to open the Advanced Mobile 4G Info window.
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Network Tab

This page displays various information about the Mobile 4G network you are currently 
connected to (if any).

IP Address
The Internet address your computer is using for the current Mobile 4G network connection. 
Ordinarily, the address displayed here is assigned only for the duration of the current 
connection. It is most likely NOT permanently assigned to your computer.

Gateway
The address of the device that is responsible for routing all the network traffic you send via 
Mobile 4G.

DNS Server
The address of the server your computer is using to translate textual Internet addresses (like 
XFINITY.com) into numerical addresses used natively by the Internet Protocol.

DHCP Server
The address of the server that assigned your computer's network configuration for the current 
Mobile 4G connection.

WINS Server
The address of the server (if any) that your computer is using to find the names used by 
computers in a Windows workgroup.
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Activity
The number of packets of data that your computer has sent and received over the WiMAX 
connection since it was established.

Advanced Mobile 4G Information
Clicking the Advanced button on the Device page of the Mobile 4G Info window produces the 
Advanced Mobile 4G Info window (shown below). This window provides advanced information 
for troubleshooting a Mobile 4G connection.

Rx Power
The strength of the signal received.

CINR
Carrier to Interference + Noise Ratio. This is an indication of how strong the desired signal is 
compared to any interfering signals and noise. This gives a slightly more accurate indication of 
the overall quality of the signal received than just the signal strength by itself.

BSID
Base Station ID. The ID of the base station you are currently connected to.

TX Power
The level of power your XFINITY Mobile 4G Internet Device is using to transmit.

Preamble Index
The Preamble Index of the Mobile 4G base station sector you are currently connected to.
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About XFINITY Connection Manager
Select About XFINITY Connection Manager from the Help menu to see the version number of 
the XFINITY Connection Manager software as well as the website for XFINITY customer 
service.

Click the System Info button to see information about your computer's current configuration, 
which may be useful to a customer service representative in resolving a problem.
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9Troubleshooting 
Procedures

Numbered Errors
The most commonly-reported connection errors are listed below, along with some advice on 
their resolution.

Error 67 
Possible causes for this error include the following:

• Mobile Internet Device account credentials have changed.

• Mobile Internet Device is no longer provisioned for service.

Resolution
• Select Update Services from the Tools > Settings > Update tab to manually update your 

service profile and parameters for your device.

• Contact XFINITY Internet 2go Technical Support at 1-866-206-2182 to ensure that your 
device is properly provisioned and that there are no problems with the account.

Error 131
Your Mobile Internet Device account credentials may have changed.

Resolution
• Select Update Services from the Tools > Settings > Update tab to manually update your 

service profile and parameters for your device.

• Contact XFINITY Internet 2go Technical Support to ensure that your device is properly 
provisioned and that there are no problems with the account.

Error 619
A connection to the remote computer could not be established, so the port used for this 
connection was closed. Possible causes for this error include the following:
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• Network resources are unavailable.

• Attempting to reconnect before your Mobile Internet Device has finished disconnecting 
from a previous call.

• Your Mobile Internet Device may be malfunctioning.

Resolution
• Wait 30 seconds, and then try to connect again.

• Remove the Mobile Internet Device and reattach it to the computer.

• Reboot the computer.

Error 628
The connection was terminated by the remote computer before it could be completed. Possible 
causes for this error include the following:

• Call was dropped due to poor signal.

• Call was dropped due to network congestion.

Resolution
• If indoors, move closer to a window, exterior wall or move to a higher level. Re-orienting 

the computer/wireless device may help as well.

• Wait 30 seconds, and then try to connect again.

Error 633
The device is already in use or is not configured properly. Possible causes for this error 
include:

• There is a problem with the drivers installed for the wireless device.

• Another application such as a fax program or PDA device software is attempting to use 
the port.

Resolution
• Shut down all FAX and PDA software and launch the again. Examples of common 

applications that can cause this type of problem include: PalmSource Hotsync, Microsoft 
ActiveSync, and Blackberry Desktop Manager.
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• Uninstall any other wireless device connection management software installed on the 
computer.

• Reinstall the XFINITY Connection Manager.

Error 635
The device is already in use or is not configured properly.

Possible causes
Unknown error. Possible causes for this error include:

• Resuming the computer system from standby

Resolution
• Close the XFINITY Connection Manager.

• Remove the Mobile Internet Device.

• Re-open the XFINITY Connection Manager.

• Connect the Mobile Internet Device.

• Reboot the computer if the steps above do no work.

Error 668 
The connection was dropped. Possible causes for this error include:

• Recent service change to the device.

• Poor signal.

• Network congestion.

Resolution
• If a service change has been requested recently, you may need to update your service 

profile and parameters for your device by selecting the Update Services option from the 
Error Dialog.

• Select Update Services from the Tools > Settings > Update tab to manually update your 
service profile and parameters for your device.

• If indoors, move closer to a window, exterior wall, or a higher level. Reorienting the 
computer or wireless device may help as well.
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• Reboot the computer.

• Contact XFINITY Internet 2go Technical Support at 1-866-206-2182 to ensure that your 
device is properly provisioned.

Error 678
The remote computer is not responding. Possible causes for this error include:

• Recent service change to the device.

• Poor signal.

• Network resources are unavailable.

Resolution
• If a service change has been requested recently, you may need to update your service 

profile and parameters for your device by selecting the Update Services option from the 
Error Dialog.

• Select Update Services from the Tools > Settings > Update tab to manually update your 
service profile and parameters for your device.

• If indoors, move closer to a window or exterior wall or move to a higher level. Reorienting 
the computer or wireless device may help as well.

• Wait 30 seconds, and then try to connect again.

• Contact XFINITY Internet 2go Technical Support at 1-866-206-2182 to ensure that your 
device is properly provisioned.

Error 691
Access was denied because user name and/or password supplied is invalid on the domain. 
Possible causes for this error include:

• Poor signal.

• Mobile Internet Device account credentials have changed.

Resolution
• If indoors, move closer to a window or exterior wall or move to a higher level. Re-orienting 

the computer/wireless device may help as well.

• Reboot the computer.
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• Select Update Services from the Tools > Settings > Update tab to manually update your 
service profile and parameters for your device.

• Contact XFINITY XFINITY Internet 2go Technical Support to ensure that your device is 
properly provisioned.

Error 692 
There was a hardware failure in the device. Possible causes of this error include:

• Wireless device is defective or broken.

• Problem with PC Card Slot, ExpressCard slot, or USB port. 

Resolution
• Close the XFINITY Connection Manager, reinsert the device, and launch the XFINITY 

Connection Manager again.

• Reboot the computer.

• Try connecting the device to another slot (or port).

Error 718
PPP/Network Timeout. Possible causes for this error include:

• Recent service change to the device.

• Poor signal.

• Network resources are unavailable.

Resolution
• If a service change has been requested recently, you may need to update your service 

profile and parameters for your device by selecting the Update Services option from the 
Error Dialog.

• Select Update Services from the Tools > Settings > Update tab to manually update your 
service profile and parameters for your device.

• If indoors, move closer to a window or exterior wall or move to a higher level. Reorienting 
the computer or wireless device may help as well.

• Wait 30 seconds, and then try to connect again.

• Reboot the computer.
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Error 719
PPP termination by remote machine. Possible causes for this error include the following:

• Poor signal.

• Network resources are unavailable.

Resolution
• If indoors, move closer to a window or exterior wall, or move to a higher level. Reorienting 

the computer or wireless device may help as well.

• Wait 30 seconds, and then try to connect again.

• Reboot the computer.

Error 777
The connection attempt failed because the connecting device on the remote computer is out of 
order. Possible causes for this error include:

• Poor signal.

• Network resources are unavailable.

• There is a problem with one of the wireless device drivers.

Resolution
• If indoors, move closer to a window or exterior wall, or move to a higher level. Reorienting 

the computer or wireless device may help as well.

• Wait 30 seconds, then try to connect again.

• Close the XFINITY Connection Manager, reinsert the wireless device and launch the 
XFINITY Connection Manager again.

• Reboot the computer.

• Uninstall any other software that manages wireless connections (if any are present on the 
computer).

• Reinstall the XFINITY Connection Manager.

Application Launch Issues
In some instances you may encounter application launch issues which can easily be resolved.
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Auto launching of the XFINITY Connection Manager at Startup
The XFINITY Connection Manager installation can be configured to allow the application to 
automatically launch when a computer boots up or when a new user logs into the machine. 
This may (or may not) be the way you prefer it to behave.

Resolution — You can access the setting that controls this behavior by selecting Settings from 
the Tools menu and then choosing the General tab. Check (or uncheck) the Automatically run 
this application on machine startup box to specify whether the XFINITY Connection Manager 
should be automatically launched.

Windows XP's native WiFi management is shut down at startup
This behavior is intentional. XFINITY Connection Manager provides significantly more powerful 
WiFi management than XP's native WiFi engine. However, if you prefer XP's native tool, you 
can disable the XFINITY Connection Manager's WiFi management entirely. 

Device Issues
In some circumstances, the XFINITY Connection Manager will not be able to use your WiFi, 
Mobile 3G or Mobile 4G Device.

A network name displayed in the main window will turn gray when the corresponding device’s 
presence has been disabled or if the device's presence is not detected by the XFINITY 
Connection Manager.

• Device Disabled (Top FAQs “Why is my device disabled?” on page 76)

• No Wireless Device Detected (Top FAQs “Why is my wireless device not detected?” on 
page 77)



– 73 – 

10Support

Support Information
Support for the XFINITY Connection Manager can be obtained through XFINITY's website at 
http://customer.comcast.com/2go

Visit the FAQ section for troubleshooting tips on Top FAQs to connect to the XFINITY Internet 
2go service.

Further assistance is available by phone at 1-866-206-2182
When contacting XFINITY Internet 2go Technical Support be sure to include the version of 
Windows and the type of wireless device you are using as well a description of the problem you 
are experiencing.
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11FAQs 

Frequently Asked Questions

I Cannot Connect.
If this is the first time the device is used, it may take 3-5 minutes for the device to be installed, 
configured and activated.

• Option 1: Re-insert Mobile Broadband device

– Remove device, wait 10 seconds, re-insert device and try to connect again.

– If above did not work: Remove device, then File > Exit the XFINITY Connection 
Manager and wait 20 sec. Re-launch the XFINITY Connection Manager, re-insert device 
to a different USB port if available, and try again.

• Option 2: Reboot computer

– Remove device and reboot computer. With the XFINITY Connection Manager running, 
re-insert device, and try to connect again.

• Option 3: Update the service

– If you have a Mobile 3G Broadband device, the device profile may need to be updated. 

– Start XFINITY Connection Manager, insert device. Select Update Services from Tools > 
Settings > Update tab to manually update service profile and parameters for your device.

– Once the update process is complete, the device will restart and attempt to connect. 

• Option 4: Update XFINITY Connection Manager (must have Internet available) 

– Start XFINITY Connection Manager, click on Tools > Check for Updates

– If an update is available, download and install it.

–  Launch XFINITY Connection Manager, re-insert device and try to connect again.

• Option 5: Disable WiFi on machine

– Click the start menu and open control panel.

– Click on "Network and Internet Connections" or "Network Connection"

•  In Windows 7 and Vista
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– Click the "View Network Status and Tasks" to open Network Sharing 
center.

– Click Change Adapter Settings on the left menu

– Right click on WiFi adapter and disable

•  In Windows XP 

– The network connections window lists all High-Speed Internet 
connections

– Right click the "Wireless Network Connection" and disable 

– You can right click on WiFi adapter and re-enable it at any time.

– Launch XFINITY Connection Manager, re-insert device and try to connect 
again.

If you are trying to connect to the 4G network you must have a Dual Mode device. Single Mode 
devices can only connect to the 3G network. If you are interested in 4G service please contact 
billing to change your plan and get the appropriate device.

Which operating systems does the XFINITY Connection Manager 
support?
The XFINITY Connection Manager supports Windows XP, Windows Vista 32-bit and 64-bit, 
and Windows 7 32-bit and 64-bit systems. See Top FAQs for more information on supported 
system configurations. 

The XFINITY Connection Manager launched, but no wireless device 
is detected.
For troubleshooting instructions, see “Why is my wireless device not detected?” on page 77.

How do I stop the XFINITY Connection Manager from launching every 
time I restart my computer?
Follow these steps:

1. Select Tools > Settings from the main menu.

2. Select the General tab.

3. Remove the check from the Automatically run this application on machine startup box.

4. Click the OK button.
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Why Does the XFINITY Connection Manager keep scanning for WiFi 
networks?
The XFINITY Connection Manager will continue to scan until it finds one or more available 
networks or hot spots. If it keeps scanning, there are most likely no WiFi networks or hot spots 
in the area. “Closed” networks are a special case. Although the XFINITY Connection Manager 
can detect whether closed networks are in the area, it cannot actually identify (or connect to) 
individual closed networks without probing for these networks using their exact names. To 
enable this, you have to create a profile for the network you wish to connect to. See “WiFi Info” 
on page 23 for more information.

Why do I keep losing my connection?
This may be due to interference by other devices like cordless phones, microwave ovens, and 
other 2.4GHz band devices. Move a few feet away from such devices. Interference can also be 
caused when in steel frame buildings, on fast moving trains, in rural or mountainous areas, on 
underground subways and near high voltage lines.

Why am I unable to connect to a network that I can see in the XFINITY 
Connection Manager?
Signal strength from the wireless Access Point may not be strong enough to allow reliable 
connections. It may not be a publicly available Access Point. Many companies or campuses 
use wireless networking within their buildings, but will not grant public access.

Why is my device disabled?
In some circumstances, the XFINITY Connection Manager will not be able to use your Wi-Fi, 
Mobile 3G Internet Device or Mobile 4G Internet Device. A network name displayed in the main 
window will turn gray when the corresponding device has been disabled or if the device’s 
presence is not currently detected by the XFINITY Connection Manager. All the devices used 
by the XFINITY Connection Manager can be disabled by Microsoft Windows. If this is the case, 
you can re-enable the device. If this is the case, you can re-enable the device. You can enable 
an attached wireless device by selecting Enable Mobile 3G, Enable Mobile 4G or Enable WiFi 
from the File menu.



– 77  –

Note: On Windows Vista systems, these options may be grayed out at all times. This may be 
because of security restrictions in your Microsoft Vista security configuration. Running the 
application as an administrator may allow access to these options.

Follow these steps:

1. Close the XFINITY Connection Manager.

2. Right click on the XFINITY Connection Manager icon on your computer’s desktop. A short 
menu appears.

3. Select Run As Administrator from this menu.

Why is my wireless device not detected?
Failure to detect the device may result from any of the following causes: 

• Devices that must be tethered to your computer with a data cable (such as USB), but are 
not currently properly connected. Make sure the cables for devices that require them are 
properly attached to both your computer and the device.

• External devices that are not currently powered on. Make sure external devices are 
switched on. Make sure the batteries of battery-powered devices are charged. Make sure 
devices that must be plugged into an electrical outlet are plugged in.

• PC Card, USB, or Express Card devices that are not properly inserted. Make sure such 
devices are firmly seated in the appropriate slots.

• The wrong device is selected in the Hardware Tab of the Settings Window. Ordinarily, 
automatic selection should be specified in the “Selected” column. If Manual selection is 
specified, verify that the selected device is the device you are trying to use. See “Settings: 
Hardware” on page 44 for more information.

• No driver or incorrect driver installed. Ensure that the latest drivers for the device are 
correctly installed according to the instructions of the device’s manufacturer.

I am receiving PPP errors when trying to connect to Mobile 3G
If a service change has been requested recently, you may need to update your service profile 
and parameters for your device by selecting the Update Services option.

 If a temporary network problem causes the connection error, use Retry Connection to connect 
to 3G again after 30 seconds.
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Use the Click Here link to view more troubleshooting topics and suggestions.

Why can't the XFINITY Connection Manager find a WiFi network?
The XFINITY Connection Manager will continue to scan until it finds one or more available 
networks or Hot Spots. Most likely, there are no WiFi Hot Spots within range.

Does XFINITY Connection Manager support WEP encryption?
Yes, XFINITY Connection Manager supports ASCII 64, 128 and HEX 64, 128.

Can I leave my card in the USB slot all the time even when not using 
it?
No, you should only have the card inserted when you are going to use it.

My card feels very hot when I remove it from the USB slot after use.
This is normal and will not affect your card.

Can I use my card on another laptop?
Yes. You will need to install the XFINITY Connection Manager software on the laptop you plan 
to use.
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Will I be charged for the time I use the card?
It depends on the plan you subscribe to. All plans offer an initial amount of data included in the 
plan and after you reach that limit you will be charged overage.

The LED light on my card is off.
The card has no power or is off. Remove the card and reinsert it.

The LED light on my card is solid?
An error has occurred. Remove the card and reinsert it.

The LED light on my card is blinking?
The card is ready to use.
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